Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 5266 | Accepted: 2172 |
Description
Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.
Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri <ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.
Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.
Input
* Line 1: Three space-separated integers: N, M, and R
* Lines 2..M+1: Line i+1 describes FJ's ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi
Output
* Line 1: The maximum number of gallons of milk that Bessie can product in the N hours
Sample Input
12 4 2 1 2 8 10 12 19 3 6 24 7 10 31
Sample Output
43
类似于求最长上升子序列的感觉 不过要注意处理右边界+r就好了 - -
AC代码如下:
//
// POJ 3616 Milking Time
//
// Created by TaoSama on 2015-03-04
// Copyright (c) 2015 TaoSama. All rights reserved.
//
#include <algorithm>
#include <cctype>
#include <cmath>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <iomanip>
#include <iostream>
#include <map>
#include <queue>
#include <string>
#include <set>
#include <vector>
#define CLR(x,y) memset(x, y, sizeof(x))
using namespace std;
const int INF = 0x3f3f3f3f;
const int MOD = 1e9 + 7;
const int N = 1e6 + 10;
int n, m, r, dp[1005];
struct Seg {
int l, r, v;
bool operator<(const Seg& rhs) const {
return l < rhs.l;
}
} a[1005];
int main() {
#ifdef LOCAL
freopen("in.txt", "r", stdin);
// freopen("out.txt","w",stdout);
#endif
ios_base::sync_with_stdio(0);
while(cin >> n >> m >> r) {
for(int i = 1; i <= m; ++i) {
cin >> a[i].l >> a[i].r >> a[i].v;
a[i].r += r;
}
sort(a + 1, a + 1 + m);
memset(dp, 0, sizeof dp);
for(int i = 1; i <= m; ++i) {
dp[i] = a[i].v;
for(int j = 1; j < i; ++j)
if(a[i].l >= a[j].r)
dp[i] = max(dp[i], dp[j] + a[i].v);
}
int ans = *max_element(dp + 1, dp + 1 + m);
cout << ans << endl;
}
return 0;
}