Battle City(BFS)

37 篇文章 0 订阅
Battle City
Time Limit: 1000MS  Memory Limit: 65536K
Total Submissions: 6880  Accepted: 2326

Description

Many of us had played the game "Battle city" in our childhood, and some people (like me) even often play it on computer now. 

What we are discussing is a simple edition of this game. Given a map that consists of empty spaces, rivers, steel walls and brick walls only. Your task is to get a bonus as soon as possible suppose that no enemies will disturb you (See the following picture). 

Your tank can't move through rivers or walls, but it can destroy brick walls by shooting. A brick wall will be turned into empty spaces when you hit it, however, if your shot hit a steel wall, there will be no damage to the wall. In each of your turns, you can choose to move to a neighboring (4 directions, not 8) empty space, or shoot in one of the four directions without a move. The shot will go ahead in that direction, until it go out of the map or hit a wall. If the shot hits a brick wall, the wall will disappear (i.e., in this turn). Well, given the description of a map, the positions of your tank and the target, how many turns will you take at least to arrive there?

Input

The input consists of several test cases. The first line of each test case contains two integers M and N (2 <= M, N <= 300). Each of the following M lines contains N uppercase letters, each of which is one of 'Y' (you), 'T' (target), 'S' (steel wall), 'B' (brick wall), 'R' (river) and 'E' (empty space). Both 'Y' and 'T' appear only once. A test case of M = N = 0 indicates the end of input, and should not be processed.

Output

For each test case, please output the turns you take at least in a separate line. If you can't arrive at the target, output "-1" instead.

Sample Input

3 4
YBEB
EERE
SSTE
0 0

Sample Output

8

 

       题意:

       给出 n,m 的地图,Y 代表所在位置,T 代表目标位置,E 代表空地, S 代表铁墙, R 代表河流, B 代表木墙,攻破木墙需要攻破为空地才能走,铁墙跟河流是无论如何都不能走的,问到达目标位置的最小步数,不能到达则输出 -1。

 

        思路:

        BFS。B 为走两步,E 为走一步,用 dis 记录到达每个位置所需的最小值,初始化为无穷大,当这个位置步数有更新的时候就进队,最后判断目标位置的步数即可。

 

        AC:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>

using namespace std;

const int INF = 99999999;

typedef struct {
    int x, y, ans;
} node;

char Map[305][305];
int dis[305][305];
int dir[4][2] = {1, 0, 0, 1, -1, 0, 0, -1};
int n, m, sx, sy, ex, ey;

void bfs () {
    node from;
    from.x = sx;
    from.y = sy;
    from.ans = 0;
    dis[sx][sy] = 0;

    queue<node> q;
    q.push(from);
    while (!q.empty()) {

        node a = q.front(); q.pop();

        for (int i = 0; i < 4; ++i) {
            node b;
            b.x = a.x + dir[i][0];
            b.y = a.y + dir[i][1];
            if (b.x >= 0 && b.x < n &&
                b.y >= 0 && b.y < m &&
                Map[b.x][b.y] != 'S' &&
                Map[b.x][b.y] != 'R') {
                    if (Map[b.x][b.y] == 'E') b.ans = a.ans + 1;
                    else b.ans = a.ans + 2;

                    if (b.ans < dis[b.x][b.y]) {
                        dis[b.x][b.y] = b.ans;
                        q.push(b);
                    }
                }
        }
    }

    if (dis[ex][ey] == INF) printf("-1\n");
    else printf("%d\n", dis[ex][ey]);
}

int main() {

    while (~scanf("%d%d", &n, &m) && (n + m)) {

        for (int i = 0; i < n; ++i) {
            for (int j = 0; j < m; ++j) {
                scanf(" %c", &Map[i][j]);
                dis[i][j] = INF;
                if (Map[i][j] == 'Y') {
                    sx = i;
                    sy = j;
                } else if (Map[i][j] == 'T') {
                    ex = i;
                    ey = j;
                }
            }
        }

        Map[ex][ey] = 'E';
        bfs();
    }

    return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值