PAT-A1013 Battle Over Cities 题目内容及题解

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city​1​​-city​2​​ and city​1​​-city​3​​. Then if city​1​​ is occupied by the enemy, we must have 1 highway repaired, that is the highway city​2​​-city​3​​.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output Specification:

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input:

3 2 3
1 2
1 3
1 2 3

Sample Output:

1
0
0

题目大意

题目给出一个无向图,内容为若干城市(节点),以及连接城市的高速公路(无向边);题目关注去掉某个节点与连接该节点的所有边后需要增加多少条边才能使图保持联通。

解题思路

  1. 初始化无向图;
  2. 将关注的节点vis数组设置为1后通过DFS检查图中有多少联通子图,将联通子图数量减一后输出即可;
  3. 初始化vis数组后对每个需要关注的节点重复第二步;
  4. 完成后返回0值。

代码

#include<stdio.h>

#define MAXN 1010

char Graph[MAXN][MAXN];
int vis[MAXN];
int N,M,K;

void Init(){
    int i,j;
    int a,b;
    scanf("%d",&N);
    for(i=1;i<=N;i++){
        for(j=1;j<=N;j++){
            Graph[i][j]='0';
        }
    }
    scanf("%d%d",&M,&K);
    for(i=0;i<M;i++){
        scanf("%d%d",&a,&b);
        Graph[a][b]='1';
        Graph[b][a]='1';
    }
    return;
}

void DFS(int n){
    int i;
    vis[n]=1;
    for(i=1;i<=N;i++){
        if((Graph[n][i]=='1')&&(vis[i]==0)){
            DFS(i);
        }
    }
    return;
}

void check(int miss){
    int i,count=-1;
    for(i=1;i<=N;i++){
        vis[i]=0;
    }
    vis[miss]=1;
    for(i=1;i<=N;i++){
        if(vis[i]==0){
            count++;
            DFS(i);
        }
    }
    printf("%d\n",count);
    return;
}

int main(){
    int i;
    int temp;
    Init();
    for(i=0;i<K;i++){
        scanf("%d",&temp);
        check(temp);
    }
    return 0;
}

运行结果

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值