PAT1005 Spell It Right

计算各个数字的和,并用英文将字母一个一个输出。 

Sample Input: 
12345 
Sample Output: 
one five 

 

 

 

#include <iostream>
#include <string>
using namespace std;

char* fun(int x)
{
	switch(x)
	{
	case 0:
		return "zero";
	case 1:
		return "one";
	case 2:
		return "two";
	case 3:
		return "three";
	case 4:
		return "four";
	case 5:
		return "five";
	case 6:
		return "six";
	case 7:
		return "seven";
	case 8:
		return "eight";
	case 9:
		return "nine";
	default:
		return NULL;
	}
}

int main()
{
	int sum = 0;
	string str;
	cin>>str;
	for(int i = 0; i < str.length(); i++)
	{
		sum = sum + (str.at(i) - '0');
	}
	int x = sum/100;
	int y = (sum - x*100)/10;
	int z = sum%10;
	if( x > 0)
	{
		cout<<fun(x)<<" "<<fun(y)<<" "<<fun(z);;
	}
	else
	{
		if( y > 0)
		{
			cout<<fun(y)<<" "<<fun(z);
		}
		else
		{
			cout<<fun(z);
		}
	}

	return 0;
}
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值