#POJ1463#Strategic Game(贪心 or Hungary or 树形DP)

15 篇文章 0 订阅

Strategic game
Time Limit: 2000MS Memory Limit: 10000K
Total Submissions: 8409 Accepted: 3931

Description

Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him? 

Your program should find the minimum number of soldiers that Bob has to put for a given tree. 

For example for the tree: 
the solution is one soldier ( at the node 1).

Input

The input contains several data sets in text format. Each data set represents a tree with the following description: 

  • the number of nodes 
  • the description of each node in the following format 
    node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifiernumber_of_roads 
    or 
    node_identifier:(0) 
The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500);the number_of_roads in each line of input will no more than 10. Every edge appears only once in the input data.

Output

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following:

Sample Input

4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)

Sample Output

1
2

题意:
鲍勃喜欢玩战略游戏。现在有n个城市,他们构成了一棵树。
鲍勃可以在某些城市派一个士兵守护,该士兵可以瞭望到所有与该城市相连的边。
问鲍勃最少要派遣多少个士兵,才能把所有的边都瞭望到。 N <= 1500

这题有三种做法:贪心 匈牙利匹配 和 树形DP,现在只讲最快的贪心法

将图做成无向图。
从度为1的节点开始想,这种节点是必须看到的,但是如果放在它们的位置上,显然不如放在与之相连的位置上好
(因为这样能看见更多的士兵,而且摆放的数量也会更少,请想一想)
我们将与它们相连的点摆上士兵,然后删除度为1节点的边,并且也删除已摆放士兵的节点的边,
剩下的图中,会再次出现度为1的点,重复以上操作。

Code:
Status Accepted
Time 234ms
Memory 1804kB
Length 1393
Lang G++
Submitted
Shared
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<algorithm>
#include<vector>
#include<queue>
#include<cstring>
using namespace std;

const int Max = 1500;

int num[Max + 5];
vector<int>Tr[Max + 5];
queue<int>Q;
bool vis[Max + 5];

bool  getint(int & num){
    char c;    int flg = 1;    num = 0;
    while((c = getchar()) < '0' || c > '9')    if(c == '-')    flg = -1;
    while(c >= '0' && c <= '9')    {    num = num * 10 + c - 48;    c = getchar();}
    num *= flg;
	return 1;
}

int main(){
	int N;
	while(~scanf("%d", &N)){
		int r, x, n;
		for(int i = 1; i <= N; ++ i){
			getint(r),getint(n);
			for(int j =1; j <= n; ++ j)
				getint(x),
				Tr[r].push_back(x),
				Tr[x].push_back(r),
				++ num[x], ++ num[r];
		}
		if(N == 1){
			printf("1\n");
			continue;
		}
		for(int i = 0; i < N; ++ i)
			if(num[i] == 1)
				Q.push(i);
		int Ans = 0;
		while(! Q.empty()){
			int tmp = Q.front();	Q.pop();
			if(vis[tmp])	continue;
			for(int i = 0; i < (int)Tr[tmp].size(); ++ i)	if(! vis[Tr[tmp][i]]){
				++ Ans;
				int u = Tr[tmp][i];
				vis[u] = 1;
				for(int j = 0; j < (int)Tr[u].size(); ++ j){
					-- num[Tr[u][j]];
					if(! vis[Tr[u][j]] && num[Tr[u][j]] == 1)
						Q.push(Tr[u][j]);
				}
			}
		}
		printf("%d\n", Ans);
		memset(num, 0, sizeof(num));
		memset(vis, 0, sizeof(vis));
		for(int i = 0; i < N; ++ i)
			Tr[i].clear();
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值