区间覆盖问题 (POJ2376) 万恶的奶牛

传送门:http://bailian.openjudge.cn/practice/2376 

                                                     Cleaning Shifts

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T. 

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval. 

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.

Input

* Line 1: Two space-separated integers: N and T 

* Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.

Output

* Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.

Sample Input

3 10
1 7
3 6
6 10

Sample Output

2

 

33的代码

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
struct seg{int l, r;};
seg s[25000];
bool cmp(seg a, seg b)
{
	return a.l < b.l;
}
int main()
{
	int n, t;
	cin >> n >> t;
	for (int i = 0; i < n; i++)
		cin >> s[i].l >> s[i].r;
	sort(s, s + n, cmp);
	int ans = 0;
	int maxr = 0;
	for (int i = 0; i < n && maxr < t; )
	{
		int nxtr = 0;
		while (i < n && s[i].l <= maxr + 1)
			nxtr = max(nxtr, s[i++].r);
		if (nxtr > maxr)
		{
			maxr = nxtr;
			ans += 1;
		}
		else
			break;
	}
	if (maxr < t)
		cout << -1 << endl;
	else
		cout << ans << endl;
    return 0;
}

 

好好反省一下为什么自己写不出(菜

注意1 2; 3 4; 5 6; 这样也是连续的。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值