【POJ 3279】Fliptile(状压DP+搜索)

Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word “IMPOSSIBLE”.

Input

Line 1: Two space-separated integers: M and N
Lines 2.. M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white
Output
Lines 1.. M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

PS

好坑啊这题,出题人竟然把这题放在简单搜索的专题里。当时我做这题时的内心呀,简直了。搜了题解才发现这是状压DP的题目,对于的入门的我,我就想问:这有办法做?
以下部分均摘自大神题解:http://www.mamicode.com/info-detail-925466.html

加了一些注释,是本渣渣在看了状压DP基本思想后理解的。还去掉了一些大神的模版部分,看上去会简洁一点。

题目大意

农夫约翰知道聪明的牛产奶多。于是为了提高牛的智商他准备了如下游戏。有一个M×N 的格子,每个格子可以翻转正反面,它们一面是黑色,另一面是白色。黑色的格子翻转后就是白色,白色的格子翻转过来则是黑色。游戏要做的就是把所有的格子都翻转成白色。不过因为牛蹄很大,所以每次翻转一个格子时,与它上下左右相邻接的格子也会被翻转。因为翻格子太麻烦了,所以牛都想通过尽可能少的次数把所有格子都翻成白色。现在给定了每个格子的颜色,请求出用最小步数完成时每个格子翻转的次数。最小步数的解有多个时,输出字典序最小的一组。解不存在的话,则输出IMPOSSIBLE。

思路

首先,同一个格子翻转两次的话就会恢复原状,所以多次翻转是多余的。此外,翻转的格子的集合相同的话,其次序是无关紧要的。因此,总共有2NM种翻转的方法。不过这个解空间太大了,我们需要想出更有效的办法。让我们再回顾一下前面的问题。在那道题中,让最左端的牛反转的方法只有1种,于是用直接判断的方法确定就可以了。同样的方法在这里还行得通吗?不妨先看看最左上角的格子。在这里,除了翻转(1,1)之外,翻转(1,2)和(2,1)也可以把这个格子翻转,所以像之前那样直接确定的办法行不通。于是不妨先指定好最上面一行的翻转方法。此时能够翻转(1,1)的只剩下(2,1)了,所以可以直接判断(2,1)是否需要翻转。类似地(2,1)~(2,N)都能这样判断,如此反复下去就可以确定所有格子的翻转方法。最后(M,1)~(M,N)如果并非全为白色,就意味着不存在可行的操作方法。像这样,先确定第一行的翻转方式,然后可以很容易判断这样是否存在解以及解的最小步数是多
少,这样将第一行的所有翻转方式都尝试一次就能求出整个问题的最小步数。这个算法中最上面一行的翻转方式共有2N种,复杂度为O(MN2N)。

代码

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;
const int maxn=16;
const int INF=0x3f3f3f3f;

int n,m; 
int t,ans,res,cnt,tmp;
int map[maxn][maxn];//状态之前 
int flip[maxn][maxn];//状态中间
int Res[maxn][maxn];//状态之后

int movv[5][2]={{1,0},{0,1},{0,0},{-1,0},{0,-1}};

bool ok(int dx,int dy)//判断是否越界 
{
    if(dx>=0&&dx<n&&dy>=0&&dy<m) return true;
    return false;
}

int getchange(int x,int y)//判断(x,y)的颜色
{
    int c=map[x][y];
    for(int i=0;i<5;i++)
    {
        int dx=x+movv[i][0];
        int dy=y+movv[i][1];
        if(ok(dx,dy)) c+=flip[dx][dy];
    }
    return c&1;//奇数为1,偶数为0; 
} 

int calc()
{
    //求出第二行开始的翻转方法
    for(int i=1;i<n;i++)
    {
        for(int j=0;j<m;j++)
        {
            if(getchange(i-1,j)!=0)//是白色翻转
            {
                flip[i][j]=1;
            } 
        }
    } 
    //判断最后一行是否是全白
    for(int j=0;j<m;j++)
    {
        if(getchange(n-1,j)!=0)
        {
            return -1;
        }
    } 
    //统计翻转次数
    int sum=0;
    for(int i=0;i<n;i++)
    {
        for(int j=0;j<m;j++)
        {
            sum+=flip[i][j];
        }
    } 
    return sum;
}


void getmat()
{
    for(int i=0;i<n;i++)
    {
        for(int j=0;j<m;j++)
        {
            scanf("%d",&map[i][j]);
        }
    }
}

void solve()
{
    int res=INF;
    for(int i=0;i<(1<<m);++i)//枚举第一行的情况,(1<<m)的值为2*m,因为第一行有2*m种翻转方法。 
    {
        memset(flip,0,sizeof(flip));
        for(int j=0;j<m;j++)
        {
            flip[0][m-j-1]=i>>j&1;//在i的状态下,第一行的j是否翻转  
        }
        int now=calc();
        if(now>0&&now<res)//求最小的操作数 
        {
            res=now;
            memcpy(Res,flip,sizeof(flip));
        }
    }
    if(res!=INF)
    {
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
            {
                printf("%d%c",Res[i][j],j==m-1?'\n':' ');
            }
        }
    }
    else puts("IMPOSSIBLE");
}

int main()
{
    while(~scanf("%d %d",&n,&m))
    {
        getmat();
        solve();
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值