HDU 1003 Max Sum(线性DP)

Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6

思路:

以每个点为结尾  求该点最大子序列和。

设i点权值为b,i-1点最大子序列和为a,  如果a是负数那么  以该点为结尾的最大子序列和为b,否则为a+b。

代码:

#include<stdio.h>
#define max(a,b) (a>b?a:b)

int main()
{
//l存储子序列和最大的左边界,r存储子序列和最大的右边界,c暂存当前序列左边界
//a存储前i-1项最大子序列和,b存储当前i项权值,maxn存储子序列最大和
    int T,n,i,a,b,maxn,cnt=0,l,r,c;
    scanf("%d",&T);
    while(T--)
    {
        
        scanf("%d%d",&n,&a);
        maxn=a,l=1,r=1,c=1;
        for(i=2;i<=n;i++)
        {
            scanf("%d",&b);
            if(a<0)c=i,a=b;
            else a+=b;

            if(a>maxn)
            {
                l=c;
                maxn=a;
                r=i;
            }
        }
        if(cnt++)printf("\n");
        printf("Case %d:\n%d %d %d\n",cnt,maxn,l,r);
    }
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值