POJ-1611 The Suspects

The Suspects
Time Limit: 1000MS Memory Limit: 20000K
   

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 
Once a member in a group is a suspect, all members in the group are suspects. 
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

Source

Asia Kaohsiung 2003

————————————————————午夜的分割线————————————————————

思路:并查集的水题?……看到各种“第一次并查集、一次AC留念”的帖子……我无力吐槽。只能说我太笨。

大致题意是这样的,有一个编号为0的元素,凡是跟它在同一个集合内的元素都是患者,求患者数量。关键点有两个:

1. 0所在集合

2. 0所在集合的元素个数

解决的技巧很简单,关键看对并查集的理解。首先需要一个num[ ]数组,初始化为1,表示各集合元素的个数。怎样才能使各集合的元素个数储存在集合祖先当中呢?尤其是当集合祖先改变的时候(某集合元素出现在另一集合当中)?仅仅在Union的时候,把子集合的元素数加到父集合即可。

而0所在集合,只需Find(0)即可。

代码如下:

/*
ID: j.sure.1
PROG: 
LANG: C++
*/
/****************************************/
 #include <cstdio>
 #include <cstdlib>
 #include <cstring>
 #include <algorithm>
 #include <cmath>
 #include <stack>
 #include <queue>
 #include <vector>
 #include <map>
 #include <string>
 #include <iostream>
 using namespace std;
/****************************************/
const int N = 30010;
int fa[N], num[N];

int Find(int x)
{
	int tmp;
	if(x != fa[x]) {
		tmp = fa[x];
		fa[x] = Find(tmp);
	}
	return fa[x];
}

void Union(int x, int y)
{
	int fx = Find(x), fy = Find(y);
	if(fx != fy) {
		fa[fy] = fx;
		num[fx] += num[fy];//注意是加到根结点上
	}
}

int main()
{
	int n, m, k, pa, son;
	while(~scanf("%d%d", &n, &m)) {
		if(!n && !m)	break;
		for(int i = 0; i < n; i++) {
			fa[i] = i;
			num[i] = 1;
		}
		for(int i = 0; i < m; i++) {
			scanf("%d", &k);
			scanf("%d", &pa);
			for(int j = 1; j < k; j++) {
				scanf("%d", &son);
				Union(pa, son);
			}
		}
		printf("%d\n", num[Find(0)]);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值