PAT 1139 First Contact

  1. First Contact (30)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
Unlike in nowadays, the way that boys and girls expressing their feelings of love was quite subtle in the early years. When a boy A had a crush on a girl B, he would usually not contact her directly in the first place. Instead, he might ask another boy C, one of his close friends, to ask another girl D, who was a friend of both B and C, to send a message to B – quite a long shot, isn’t it? Girls would do analogously.

Here given a network of friendship relations, you are supposed to help a boy or a girl to list all their friends who can possibly help them making the first contact.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (1 < N <= 300) and M, being the total number of people and the number of friendship relations, respectively. Then M lines follow, each gives a pair of friends. Here a person is represented by a 4-digit ID. To tell their genders, we use a negative sign to represent girls.

After the relations, a positive integer K (<= 100) is given, which is the number of queries. Then K lines of queries follow, each gives a pair of lovers, separated by a space. It is assumed that the first one is having a crush on the second one.

Output Specification:

For each query, first print in a line the number of different pairs of friends they can find to help them, then in each line print the IDs of a pair of friends.

If the lovers A and B are of opposite genders, you must first print the friend of A who is of the same gender of A, then the friend of B, who is of the same gender of B. If they are of the same gender, then both friends must be in the same gender as theirs. It is guaranteed that each person has only one gender.

The friends must be printed in non-decreasing order of the first IDs, and for the same first ones, in increasing order of the seconds ones.

Sample Input:
10 18
-2001 1001
-2002 -2001
1004 1001
-2004 -2001
-2003 1005
1005 -2001
1001 -2003
1002 1001
1002 -2004
-2004 1001
1003 -2002
-2003 1003
1004 -2002
-2001 -2003
1001 1003
1003 -2001
1002 -2001
-2002 -2003
5
1001 -2001
-2003 1001
1005 -2001
-2002 -2004
1111 -2003
Sample Output:
4
1002 2004
1003 2002
1003 2003
1004 2002
4
2001 1002
2001 1003
2002 1003
2002 1004
0
1
2003 2001
0

#include<cstdio>
#include<algorithm>
#include<vector>
using namespace std;
const int maxn=10000;

bool bg[maxn]={false};//false为女(<0),true为男(>0)
vector<int>G[maxn];
int n,m,q;
int st,ed;
int ans[maxn][2];
int cnt=0;
bool vis[maxn]={false};

vector<int>path;

void dfs(int s){
    path.push_back(s);
    vis[s]=true;
    if(path.size()>4||(s!=ed&&path.size()==4)){
        path.pop_back();
        vis[s]=false;
        return;
    }
    if(s==ed&&path.size()==4){
        if(bg[path[1]]==bg[path[0]]&&bg[path[2]]==bg[path[3]]&&path[1]){
            ans[cnt][0]=path[1];
            ans[cnt][1]=path[2];
            cnt++;
        }
        path.pop_back();
        vis[s]=false;
        return;
    }
    sort(G[s].begin(),G[s].end());
    for(int i=0;i<G[s].size();i++){
        if(vis[G[s][i]]==false)dfs(G[s][i]);
    }
    path.pop_back();
    vis[s]=false;
}

int main(){
    scanf("%d %d",&n,&m);
    for(int i=0;i<m;i++){
        int a,b;
        scanf("%d %d",&a,&b);
        if(a>0)bg[a]=true;
        else a=-a;
        if(b>0)bg[b]=true;
        else b=-b;
        G[a].push_back(b);
        G[b].push_back(a);
    }
    scanf("%d",&q);
    for(int i=0;i<q;i++){
        cnt=0;
        scanf("%d %d",&st,&ed);
        if(st<0)st=-st;
        if(ed<0)ed=-ed;
        dfs(st);
        printf("%d\n",cnt);
        for(int j=0;j<cnt;j++){
            printf("%d %d\n",ans[j][0],ans[j][1]);
        }
    }
    return 0;
}

这里写图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值