PAT A1009. Product of Polynomials (25)

  1. Product of Polynomials (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < … < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 3 3.6 2 6.0 1 1.6

#include<cstdio>
const int maxn=2002;
const int maxm=1001;
double a[maxm]={0};
double b[maxm]={0};
double c[maxn]={0};

int n;
int main(){
    scanf("%d",&n);
    for(int i=0;i<n;i++){
        int id;
        scanf("%d",&id);
        scanf("%lf",&a[id]);
    }
    scanf("%d",&n);
    for(int i=0;i<n;i++){
        int id;
        scanf("%d",&id);
        scanf("%lf",&b[id]);
    }
    for(int i=0;i<maxm;i++){
        for(int j=0;j<maxm;j++){
            int e=i+j;
            double co=a[i]*b[j];
            c[e]+=co;
        }
    }
    int cnt=0;
    for(int i=0;i<maxn;i++){
        if(c[i]!=0){
            cnt++;
        }
    }
    printf("%d",cnt);
    for(int i=maxn-1;i>=0;i--){
        if(c[i]!=0){
            printf(" %d %.1f",i,c[i]);
        }
    }
    return 0;
}

这里写图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值