1141. PAT Ranking of Institutions (25)

  1. PAT Ranking of Institutions (25)

时间限制
500 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
After each PAT, the PAT Center will announce the ranking of institutions based on their students’ performances. Now you are asked to generate the ranklist.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=105), which is the number of testees. Then N lines follow, each gives the information of a testee in the following format:

ID Score School

where “ID” is a string of 6 characters with the first one representing the test level: “B” stands for the basic level, “A” the advanced level and “T” the top level; “Score” is an integer in [0, 100]; and “School” is the institution code which is a string of no more than 6 English letters (case insensitive). Note: it is guaranteed that “ID” is unique for each testee.

Output Specification:

For each case, first print in a line the total number of institutions. Then output the ranklist of institutions in nondecreasing order of their ranks in the following format:

Rank School TWS Ns

where “Rank” is the rank (start from 1) of the institution; “School” is the institution code (all in lower case); “TWS” is the total weighted score which is defined to be the integer part of “ScoreB/1.5 + ScoreA + ScoreT*1.5”, where “ScoreX” is the total score of the testees belong to this institution on level X; and “Ns” is the total number of testees who belong to this institution.

The institutions are ranked according to their TWS. If there is a tie, the institutions are supposed to have the same rank, and they shall be printed in ascending order of Ns. If there is still a tie, they shall be printed in alphabetical order of their codes.

Sample Input:
10
A57908 85 Au
B57908 54 LanX
A37487 60 au
T28374 67 CMU
T32486 24 hypu
A66734 92 cmu
B76378 71 AU
A47780 45 lanx
A72809 100 pku
A03274 45 hypu
Sample Output:
5
1 cmu 192 2
1 au 192 3
3 pku 100 1
4 hypu 81 2
4 lanx 81 2

#include<cstdio>
#include<map>
#include<algorithm>
#include<cstring>
#include<string>
#include<iostream>
using namespace std;
const int maxn=100010;

map<string,int>mp;
int cnt=0;

struct school{
    string name;
    int score;
    int a,b,c;
    int n;
    int rank;
}sch[maxn];
int n;

void init(int n){
    for(int i=0;i<n;i++){
        sch[i].n=0;
        sch[i].rank=maxn;
        sch[i].score=0;
        sch[i].a=sch[i].b=sch[i].c=0;
    }
}

bool cmp(school a,school b){
    if(a.score!=b.score)return a.score>b.score;
    else if(a.n!=b.n) return a.n<b.n;
    else return a.name<b.name;
}

void makerank(){
    sort(sch,sch+cnt,cmp);
    sch[0].rank=1;
    for(int i=1;i<cnt;i++){
        if(sch[i].score==sch[i-1].score)sch[i].rank=sch[i-1].rank;
        else sch[i].rank=i+1;
    }
}

int main(){
    scanf("%d",&n);
    init(n);
    for(int i=0;i<n;i++){
        getchar();
        char s[10];
        int score;
        string name;
        scanf("%s %d",s,&score);
        cin>>name;
        for(int j=0;j<name.length();j++){
            if(name[j]>='A'&&name[j]<='Z'){
                name[j]=name[j]-'A'+'a';
            }
        }
        if(mp.find(name)==mp.end()){
            mp[name]=cnt++;
        }
        if(s[0]=='T')sch[mp[name]].a+=score;
        else if(s[0]=='A')sch[mp[name]].b+=score;
        else sch[mp[name]].c+=score;
        sch[mp[name]].n++;
        sch[mp[name]].name=name;
    }
    for(int i=0;i<cnt;i++){
        sch[i].score=sch[i].a*1.5+sch[i].b+sch[i].c/1.5;
    }
    makerank();
    printf("%d\n",cnt);
    for(int i=0;i<cnt;i++){
        printf("%d ",sch[i].rank);
        cout<<sch[i].name<<" ";
        printf("%d %d\n",sch[i].score,sch[i].n);
    }
    return 0;
}

这里写图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值