算法--数字三角形问题

 Problem Description

给定一个由n行数字组成的数字三角形如下图所示。试设计一个算法,计算出从三角形的顶至底的一条路径,使该路径经过的数字总和最大。
  
对于给定的由n行数字组成的数字三角形,计算从三角形的顶至底的路径经过的数字和的最大值。

Input

输入数据的第1行是数字三角形的行数n,1≤n≤100。接下来n行是数字三角形各行中的数字。所有数字在0..99之间。

Output

输出数据只有一个整数,表示计算出的最大值。

Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30

#include <bits/stdc++.h>
#define INF 9999
using namespace std;
struct Coins
{
    int t;
    int c;
} coin[20];

int max(int a,int b)
{
    return a>b?a:b;
}
int main()
{
    int n;
    scanf("%d",&n);
    int a[n+1][n+1];
    int maxV[n+1][n+1];
    memset(a,0,sizeof(a));
    memset(maxV,0,sizeof(maxV));

    for(int i=1; i<=n; i++)
        for(int j=1; j<=i; j++)
        {
            scanf("%d",&a[i][j]);

        }
    for(int i=1;i<=n;i++)
        maxV[n][i] = a[n][i];
    for(int i=n-1;i>=1;i--)
    for(int j=0;j<=i;j++){
        maxV[i][j] = a[i][j]+max(maxV[i+1][j],maxV[i+1][j+1]);
    }
    printf("%d\n",maxV[1][1]);
    return 0;
}



/***************************************************

Result: Accepted
Take time: 0ms
Take Memory: 228KB
Submit time: 2019-03-18 21:13:29
****************************************************/

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值