HDU 4027 Can you answer these queries?

Time Limit:2000MS Memory Limit:65768KB

Description
A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.

Input
The input contains several test cases, terminated by EOF.
For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 2^63.
The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.

Output
For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.

Sample Input

10
1 2 3 4 5 6 7 8 9 10
5
0 1 10
1 1 10
1 1 5
0 5 8
1 4 8

Sample Output

Case #1:
19
7
6

【题意】 有n艘邪恶的战舰,每艘战舰的防护罩都有一定的能量,我军有一种武器,每轰一次,一个区间内的战舰防护罩的能量将变成原来能量的开方,0表示攻击,1表示查询,查询的则是这个区间内战舰防护罩的能量之和(注意:此题有一个坑点,查询时输入X和Y,X可能比Y大,多么痛的领悟)。

【解题思路】 该题是一个线段树单点更新,但要注意,由于是将原来的值开方,所以每次更新都必须更新叶子结点,然后再返回值,更新上层节点的值。不过数据比较大,直接这样做的话会超时的,所以,在此做出一个优化。由于总值不超过2^63,所以一个叶子结点最多被更新7次就会变为1,用一个标记来记录开方的次数,当大于等于7次的时候,就不需要再对其进行改动。

【AC代码】

#include<stdio.h>
#include<math.h>
#include<iostream>
#define fff 100010
using namespace std;
long long a[fff]; //数据会超int
struct node
{
    int l,r;
    int vis;
    long long sum;
}tr[fff*4];
void pushup(int id)
{
    tr[id].sum=tr[id*2].sum+tr[id*2+1].sum;
    if(tr[id*2].vis>=7&&tr[id*2+1].vis>=7) //若两个子节点都不再改动,该节点也不再改动
        tr[id].vis=7;
}
void build(int id,int l,int r)
{
    tr[id].l=l;tr[id].r=r;
    tr[id].vis=0;
    if(l==r)
    {
        tr[id].sum=a[l];
        return;
    }
    int mid=(l+r)/2;
    build(id*2,l,mid);
    build(id*2+1,mid+1,r);
    pushup(id);
}
void update(int id,int l,int r)
{
    if(tr[id].vis==7) //开方达到7次则不再改动
    {
        tr[id].sum=tr[id].r-tr[id].l+1;
        return;
    }
    if(tr[id].l==l&&tr[id].r==r)
    {
        tr[id].vis+=1;
        if(l==r)
            tr[id].sum=sqrt(tr[id].sum);
        else
        {
            int mid=(l+r)/2;
            update(id*2,l,mid);
            update(id*2+1,mid+1,r);
            pushup(id);
        }
        return;
    }
    int mid=(tr[id].l+tr[id].r)/2;
    if(r<=mid)
        update(id*2,l,r);
    else if(l>mid)
        update(id*2+1,l,r);
    else
    {
        update(id*2,l,mid);
        update(id*2+1,mid+1,r);
    }
    pushup(id);
}
long long sum(int id,int l,int r)
{
    if(tr[id].l==l&&tr[id].r==r)
        return tr[id].sum;
    int mid=(tr[id].l+tr[id].r)/2;
    if(r<=mid)
        return sum(id*2,l,r);
    else if(l>mid)
        return sum(id*2+1,l,r);
    else
        return sum(id*2,l,mid)+sum(id*2+1,mid+1,r);
}
int main()
{
    int n,cas=1,i,m,x,y,z;
    while(scanf("%d",&n)!=EOF)
    {
        for(i=1;i<=n;i++)
            scanf("%lld",&a[i]);
        build(1,1,n);
        scanf("%d",&m);
        printf("Case #%d:\n",cas++);
        while(m--)
        {
            scanf("%d%d%d",&x,&y,&z);
            if(y>z)
                swap(y,z); //注意此处的坑点!!!
            if(x==0)
                update(1,y,z);
            else
                printf("%lld\n",sum(1,y,z));
        }
        printf("\n"); //该题在每个例子之后还需要再输入一个空行
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值