Ubuntu 17.10 配置 GTK+-3.0 开发环境

博客搬家还不会呢。从网易搬家到这里,一篇一篇搬到哪辈子啊?

试用了Kubuntu, Ubuntu Mate, UbuntuStudio, 后两者非常好用,最好用还是UbuntuStudio。Mate真心漂亮,也很不错。

Kubuntu--或者说KDE--非常卡顿,看来真是不想活了。
三者安装后都缺gcc,所以:
  1. 安装GCC开发环境:sudo apt install build-essential
  2. 安装pkg-config包:sudo apt install pkg-config。注意包名,系统会提示另外还有个pkgconf,不是那个。
  3. 安装gtk+-3.0:sudo apt install gtk+-3.0。一般到这里就安装好环境了,可以用CodeBlocks和Anjuta开发了。
  4. 但是还要注意有个通过安装Gnome开发环境的方法,网上有些网文包名不对,在ubuntu17.10里面要这样:sudo apt install gnome-devel gnome-devel-docs。注意gnome包名。
  5. 以上过程中还会推荐安装一些东西,有一些是可以安装的,可以加上。
安装CodeBlocks,暂时不要装contrib,似乎有bug不能编译。安装后要配置
菜单Settings-Compiler-Global compiler settings, 输入`pkg-config --cflags gtk+-3.0`
同界面Lingker Settings-Other Linker Options中输入`pkg-config --libs gtk+-3.0`
保存。
再建立新项目就有gtk+3.0的支持了。
如果是以前的项目,要在项目右键进Build Options输入这些东西。
要注意不是单引号,而是1键左边那个反斜杠方向的单引号。

另外要注意的是,在项目右键菜单下,有Build Option,在这里添加如上的pkg-config的附加选项更好,因为是随着项目走的,不会影响建立其他的非gtk的项目。上面那个抄自其他人的说法是个馊主意。

没有更多推荐了,返回首页