POJ 2251 Dungeon Master

链接: http://poj.org/problem?id=2251

Dungeon Master

Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 33415 Accepted: 12793

关键词: 三维BFS

Description

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.

Is an escape possible? If yes, how long will it take?

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size). L is the number of levels making up the dungeon. R and C are the number of rows and columns making up the plan of each level. Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.

Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape. If it is not possible to escape, print the line Trapped!

Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!

Source

Ulm Local 1997

Analyze

输出'S'到'E"花费的最少时间

Code

#include <cstdio>  
#include <cstdlib>  
#include <cstring>  
#include <cmath>  
#include <ctime>  
#include <iostream>  
#include <algorithm>  
#include <string>  
#include <queue>  
#define MAXN 35  
using namespace std;  
  
class Node  
{  
public:  
    int l, r, c;  
    int time;  
public:  
    bool operator==(const Node &rhs) const {  
        return l == rhs.l && r == rhs.r && c == rhs.c;  
    }  
};  
  
int layer, row, col;  
Node st, ed;  
bool mp[MAXN][MAXN][MAXN];  
bool flag[MAXN][MAXN][MAXN];  
int dir[6][3] = { {0, 0, 1}, {0, 0, -1}, {0, 1, 0}, {0, -1, 0}, {1, 0, 0}, { -1, 0, 0} };  
  
bool CheckValid(const Node &node)  
{  
    int l = node.l, r = node.r, c = node.c;  
  
    if (l >= 0 && l < layer && r >= 0 && r < row&& c >= 0 && c < col && mp[l][r][c])  
        return true;  
    return false;  
}  
  
int TBFS()  
{  
    int i;  
    queue<Node> q;  
    q.push(st);  
    flag[st.l][st.r][st.c] = true;  
  
    while (!q.empty())  
    {  
        Node tmp = q.front();//返回值为队列中的第一个元素,也就是最早、最先进入队列的元素。  
        q.pop();//将队列中最靠前位置的元素拿掉,是没有返回值的void函数  
  
        for (i = 0; i < 6; ++i)  
        {  
            Node node = tmp;  
            node.l += dir[i][0];  
            node.r += dir[i][1];  
            node.c += dir[i][2];  
            if (CheckValid(node) && !flag[node.l][node.r][node.c])  
            {  
                ++node.time;  
                flag[node.l][node.r][node.c] = true;  
                q.push(node);  
  
                if (node == ed)  
                {  
                    return node.time;  
                }  
            }  
        }  
    }  
    return 0;  
}  
  
int main()  
{  
    int i, j, k;  
    char ch;  
  
    while (scanf ("%d %d %d%*c", &layer, &row, &col) != EOF)  
    {  
         //注意这里的一个小小细节,%*c用来忽略输入后面的那个回车,学习了。  
        if (!layer && !row && !col)  
            break;  
        for (i = 0; i < layer; ++i) {  
            for (j = 0; j < row; ++j)   {  
                for (k = 0; k < col; ++k)   {  
                    ch = getchar();  
                    if (ch == '#')  
                        mp[i][j][k] = 0;  
                    else if (ch == '.')  
                        mp[i][j][k] = 1;  
                    else if (ch == 'S') {  
                        st.l = i;st.r = j;st.c = k;st.time = 0;mp[i][j][k] = 1;  
                    }  
                    else if (ch == 'E') {  
                        ed.l = i;ed.r = j; ed.c = k;ed.time = 0;mp[i][j][k] = 1;  
                    }  
                }  
                getchar ();  
            }  
            getchar ();  
        }  
        memset(flag, false, sizeof(flag));  
        int ret = TBFS();  
        if (ret)    printf ("Escaped in %d minute(s).\n", ret);  
        else    printf ("Trapped!\n");  
    }  
    return 0;  
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值