杭电ACM1098 Ignatius's puzzle

Problem Description
Ignatius is poor at math,he falls across a puzzle problem,so he has no choice but to appeal to Eddy. this problem describes that:f(x)=5* x^13+13* x^5+k* a*x,input a nonegative integer k(k<10000),to find the minimal nonegative integer a,make the arbitrary integer x ,65|f(x)if
no exists that a,then print “no”.

Input
The input contains several test cases. Each test case consists of a nonegative integer k, More details in the Sample Input.

Output
The output contains a string “no”,if you can’t find a,or you should output a line contains the a.More details in the Sample Output.

题目大意:给定k,求a使得对于任意x,65|f(x)=5* x^13+13* x^5+k* a*x。

分析:
65=5 * 13,
先来看5|f(x)的情况:
5|5* x^13这是显然对任意x都成立的,我们只考虑后两项就可以了,
13%5=3,根据费马小定理 x^5%5=x,所以13* x^5%5=3*x%5,
推出(13* x^5+k* a * x)%5=(3+k * a) * x %5.
要使得对于任意x,x|f(x),则(3+k * a)%5=0。
再来看13|f(x)的情况:
和上面同样的分析,我们可以得到结果:(5+k * a)%13=0;
最后根据孙子定理知道:
k*a=65 * t+47,t为某个整数。我们只要从0一直试到64就可以知道满足条件的t(条件是指对给定的k,使得a为整数)为多少了。那么就知道a等于多少了。

import java.util.Scanner;

public class IgnatiusPuzzle {

    public static void main(String args[]){
        Scanner s=new Scanner(System.in);
        while(s.hasNext()){
            int k=s.nextInt();
            int n = 0,flag=0;
            for(int t=0;t<k;t++){
                if((65*t+47)%k==0){
                    n=(65*t+47)/k;
                    flag=1;
                    break;
                }
            }
            if(flag==0){
                System.out.println("no");
            }
            else{
                System.out.println(n);
            }
        }
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
引用\[2\]提供了关于如何在杭电OJ上使用C语言进行题目刷题的步骤。首先,你需要打开百度并搜索“杭电OJ”,然后进入官网进行注册。在注册界面上填写完整的信息后点击提交。接下来,你可以使用你的用户名和密码登录账号。进入刷题界面后,你可以选择C语言作为答题语言,并将代码粘贴到答题界面中。然后你可以查看答案是否正确。如果你不小心离开了界面,你可以通过点击红线圈出部分或者点击右上方的用户名进入用户界面来查看你的题目是否正确。\[2\] 引用\[1\]提供了一段C语言代码,但是没有明确指出这段代码的作用和题目的具体要求。如果你能提供更多关于杭电OJ1098题目的信息,我将能够为你提供更准确的帮助。 #### 引用[.reference_title] - *1* [杭电OJ 2007 C语言版 已通过](https://blog.csdn.net/m0_56912916/article/details/119041984)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^control_2,239^v3^insert_chatgpt"}} ] [.reference_item] - *2* *3* [杭电OJ刷题指南(ACM)](https://blog.csdn.net/qq_38769551/article/details/101510000)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^control_2,239^v3^insert_chatgpt"}} ] [.reference_item] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值