杭电ACM——1098

Ignatius's puzzle


问题: Ignatius is poor at math,he falls across a puzzle problem,so he has no choice but to appeal to Eddy. this problem describes that:f(x)=5*x^13+13*x^5+k*a*x,input a nonegative integer k(k<10000),to find the minimal nonegative integer a,make the arbitrary integer x ,65|f(x)if
no exists that a,then print "no".

输入:The input contains several test cases. Each test case consists of a nonegative integer k, More details in the Sample Input.

输出:The output contains a string "no",if you can't find a,or you should output a line contains the a.More details in the Sample Output.

示例输入:
11
100
9999

示例输出:
22
no
43

问题分析:
           
5*x^13+13*x^5+k*a*x可以分成两部分 即 5*x^13+13*x^5 和 k*a*x;
而第一个部分我们可以发现 (5*x^13+13*x^5)% 65 结果会不断循环,循环节为65,而且为等差数列,差为18,则通过数学归纳法证明可得
只要满足(18 + k * x) % 65 == 0即可
代码如下
# include <stdio.h>


int main()
{
	int k, flag, x;
	while(scanf("%d", &k) != EOF)
	{
		flag = 0;
		for(x = 1; x <= 65; x++)
		{
			if ((18 + k * x) % 65 == 0) 
			{
				flag = 1;
				printf("%d\n", x);
				break;
			}
		}
		if (flag == 0)
		{
			printf("no\n");
		}
	}


	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值