1149 PIGS

PIGS
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 10845 Accepted: 4751

Description

Mirko works on a pig farm that consists of M locked pig-houses and Mirko can't unlock any pighouse because he doesn't have the keys. Customers come to the farm one after another. Each of them has keys to some pig-houses and wants to buy a certain number of pigs. 
All data concerning customers planning to visit the farm on that particular day are available to Mirko early in the morning so that he can make a sales-plan in order to maximize the number of pigs sold. 
More precisely, the procedure is as following: the customer arives, opens all pig-houses to which he has the key, Mirko sells a certain number of pigs from all the unlocked pig-houses to him, and, if Mirko wants, he can redistribute the remaining pigs across the unlocked pig-houses. 
An unlimited number of pigs can be placed in every pig-house. 
Write a program that will find the maximum number of pigs that he can sell on that day.

Input

The first line of input contains two integers M and N, 1 <= M <= 1000, 1 <= N <= 100, number of pighouses and number of customers. Pig houses are numbered from 1 to M and customers are numbered from 1 to N. 
The next line contains M integeres, for each pig-house initial number of pigs. The number of pigs in each pig-house is greater or equal to 0 and less or equal to 1000. 
The next N lines contains records about the customers in the following form ( record about the i-th customer is written in the (i+2)-th line): 
A K1 K2 ... KA B It means that this customer has key to the pig-houses marked with the numbers K1, K2, ..., KA (sorted nondecreasingly ) and that he wants to buy B pigs. Numbers A and B can be equal to 0.

Output

The first and only line of the output should contain the number of sold pigs.

Sample Input

3 3
3 1 10
2 1 2 2
2 1 3 3
1 2 6

Sample Output

7

Source

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <deque>
using namespace std;
#define MAXM 1000
#define MAXN 100
#define INF 300000000
int M,N;
int s,t;
int customer[MAXN+2][MAXN+2]; //容量
int flow[MAXN+2][MAXN+2];     //流量
int i,j;

void init() {
    int num,k;
    int house[MAXM]; //每个猪圈中猪的数目
    int last[MAXM]; //存储每个猪圈的前一个顾客的序号
    memset(last,0,sizeof(last));
    memset(customer,0,sizeof(customer));
    cin >> M >> N;
    s= 0; t = N+1;  //源点、汇点
    for(i=1; i<=M; i++) cin >> house[i];
    for(i=1; i<=N; i++) {
        cin >> num;
        for(j=0; j<num; j++) {
            cin >> k;
            if(last[k]==0) customer[s][i] += house[k];
            else customer[last[k]][i] = INF;
            last[k] = i;
        }
        cin >> customer[i][t];
    }
}

void ford() {
    int prev[MAXN+2];
    int minflow[MAXN+2];

    deque<int> queue;
    int qs,qe;
    int v;  //当前检查的顶点
    int p;  //用于保存Cij—Fij
    memset(flow,0,sizeof(flow));
    minflow[0] = INF;
    while(1) {
        for(i=0; i<MAXN+2; i++) prev[i] = -2;
        prev[0] = -1;
        queue.push_back(s);
        while(!queue.empty()&& prev[t] == -2) {
            v = queue.front();
            queue.pop_front();
            for(i=0; i<t+1; i++) {
                if(prev[i]==-2 && (p=customer[v][i] - flow[v][i])>0) {
                    prev[i] = v;
                    queue.push_back(i);
                    minflow[i] = min(minflow[v],p);
                }
            }
        }//end of while
        queue.clear();
        if(prev[t]== -2) break;
        i = prev[t]; j = t;
        while(i!=-1) {
            flow[i][j] += minflow[t];
            flow[j][i] = -flow[i][j];
            j = i; i = prev[i];
        }
    }//end of while
    for(i=0,p=0; i<t; i++) p += flow[i][t];
    cout << p << endl;
}

int main() {
    init();
    ford();
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值