2299 Ultra-QuickSort

Ultra-QuickSort
Time Limit: 7000MS Memory Limit: 65536K
Total Submissions: 24055 Accepted: 8603

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 
9 1 0 5 4 ,

Ultra-QuickSort produces the output 
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

Source

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
using namespace std;
#define MAX 500001

int n, a[MAX], t[MAX];
long long sum;

/* 归并 */
void Merge(int l, int m, int r) {
    /* p指向输出区间 */
    int p = 0;
    /* i、j指向2个输入区间 */
    int i = l, j = m + 1;
    /* 2个输入区间都不为空时 */
    while(i <= m && j <= r) {
        /* 取关键字小的记录转移至输出区间 */
        if (a[i] > a[j]) {
            t[p++] = a[j++];
            /* a[i]后面的数字对于a[j]都是逆序的 */
            sum += m - i + 1;
        }else {
            t[p++] = a[i++];
        }
    }
    /* 将非空的输入区间转移至输出区间 */
    while(i <= m) t[p++] = a[i++];
    while(j <= r) t[p++] = a[j++];
    /* 归并完成后将结果复制到原输入数组 */
    for (i = 0; i < p; i++){
        a[l + i] = t[i];
    }
}

/* 归并排序 */
void MergeSort(int l, int r) {
    int m;
    if (l < r) {
        /* 将长度为n的输入序列分成两个长度为n/2的子序列 */
        m = (l + r) / 2;
        /* 对两个子序列分别进行归并排序 */
        MergeSort(l, m);
        MergeSort(m + 1, r);
        /* 将2个排好的子序列合并成最终有序序列 */
        Merge(l, m, r);
    }
}

int main() {
    int i;
    while(cin >> n) {
        if (n == 0) break;
        sum=0;
        for(i = 0; i < n; i++) {
            scanf("%d", &a[i]);
        }
        MergeSort(0, n - 1);
        printf("%I64d\n", sum);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值