Can you solve this equation?

二分,函数递增,所以可以先确定y的区间,不在区间则为No solution!

Description

Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100; 
Now please try your lucky.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

Output

For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

Sample Input

2
100
-4

Sample Output

1.6152
No solution!

#include<stdio.h>
#include<math.h>
bool judge(double n);
double y,x;
int main()
{
	double le,ri,mid,max;
	int t,i;
	scanf("%d",&t);
	max=8*pow(100,4)+7*pow(100,3)+2*pow(100,2)+3*100;
	while(t--)
	{
		scanf("%lf",&y);
		y-=6;
		if(y<0||y>max)
		printf("No solution!\n");
		else
		{
			le=0;
			ri=y;
			mid=(le+ri)/2;
			while(ri-le>=0.0000000001)
			{
				if(judge(mid))
				le=mid;
				else
				ri=mid;
				mid=(le+ri)/2*1.0;
			}
			if(mid==0)
			printf("0\n");
			else
			printf("%.4lf\n",mid); 
		}
	}
}
bool judge(double n)
{
	double sum;
	sum=8*pow(n,4)+7*pow(n,3)+2*pow(n,2)+3*n;
	if(sum>=y)
	return 0;
	else
	return 1;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值