Find The Multiple
Time Limit: 1000MS | Memory Limit: 10000K | |||
Total Submissions: 29065 | Accepted: 12059 | Special Judge |
Description
Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2 6 19 0
Sample Output
10 100100100100100100 111111111111111111
Source
想过用longlong试试,wa,看了题解用unsigned longlong可以过,较坑,但你想不到就过不了
#include<stdio.h>
int flog=0;
unsigned long long int ans[205];
int dfs(unsigned long long int m,int x,int k)
{
// printf("%lld\n",m);
if(flog||k>=19)
return 0;
if(m%x==0)
{
printf("%I64u\n",m);
ans[x]=m;
flog=1;
return 0;
}
dfs(m*10,x,k+1);
dfs(m*10+1,x,k+1);
}
int main()
{
int n;
while(scanf("%d",&n),n)
{
flog=0;
dfs(1,n,0);
}
return 0;
}