poj 3279 Fliptile

13 篇文章 0 订阅

Fliptile
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 8690 Accepted: 3255

Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input

Line 1: Two space-separated integers:  M and  N 
Lines 2.. M+1: Line  i+1 describes the colors (left to right) of row i of the grid with  N space-separated integers which are 1 for black and 0 for white

Output

Lines 1.. M: Each line contains  N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

Source


之前看过这个题,不过没写,只是听了听大腿的大体思路

思路大约是如果要翻转当前的点,翻转他前面的点,来翻转他,这样就不会影响已经翻好的点,但这样最后一列没办法翻,所以枚举对第一列所有的翻转情况,按照前面的翻转方法找能使最后一列翻成符合条件的情况,记录比较找一下最小值

#include<stdio.h>
#include<string.h>
#define inf 0x3f3f3f3f
struct node
{
	int x[17][17];
	int min;
}ans,s;
void solve();
int map[17][17],mapp[17][17],n,m,k=0;
void dfs(int step)
{
	int i,j;
	if(step==n)
	{
	/*	printf("%d\n",++k);
		for(i=0;i<n;i++)
		for(j=0;j<m;j++)
		printf("%d%c",map[i][j]," \n"[j==n-1]);*/
		solve();
		return ;
	}
	s.x[step][0]++;
	map[step][0]++;
	map[step][1]++;
	if(step)
	map[step-1][0]++;
	map[step+1][0]++;
	s.min++;
	dfs(step+1);
	s.min--;
	s.x[step][0]--;
	map[step][0]--;
	map[step][1]--;
	if(step)
	map[step-1][0]--;
	map[step+1][0]--;
	dfs(step+1);
}
void solve()
{
	node ss=s;
	int i,j;
	for(i=0;i<n;i++)
	for(j=0;j<m;j++)
	mapp[i][j]=map[i][j];
	for(j=0;j<m-1;j++)
	{
		for(i=0;i<n;i++)
		{
			if(mapp[i][j]&1)
			{
				s.x[i][j+1]++;
				mapp[i][j]++;
				mapp[i][j+1]++;
				mapp[i][j+2]++;
				if(i)
				mapp[i-1][j+1]++;
				mapp[i+1][j+1]++;
				s.min++;
			}
		}
	}
	int flog=1;
	for(i=0;i<n;i++)
	{
		if(mapp[i][m-1]&1)
		flog=0;
	}
	if(flog)
	{
		if(s.min<ans.min)
		{
			ans=s;
		}
	}
	s=ss;
	return ;
}
int main()
{
	int i,j;
	scanf("%d %d",&n,&m);
	memset(ans.x,0,sizeof(ans.x));
	memset(s.x,0,sizeof(s.x));
	s.min=0;
	ans.min=inf;
	for(i=0;i<n;i++)
	for(j=0;j<m;j++)
	scanf("%d",&map[i][j]);
	dfs(0);
	if(ans.min==inf)
	printf("IMPOSSIBLE\n");
	else
	for(i=0;i<n;i++)
	{
		for(j=0;j<m;j++)
		printf("%d%c",ans.x[i][j]," \n"[j==m-1]);
	}
	return 0;
 }


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值