【PAT】1077 Kuchiguse (20分)---字符串处理

1077 Kuchiguse (20分)

-----题目链接-----
The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker’s personality. Such a preference is called “Kuchiguse” and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle “nyan~” is often used as a stereotype for characters with a cat-like personality:

  • Itai nyan~ (It hurts, nyan~)
  • Ninjin wa iyada nyan~ (I hate carrots, nyan~)

Now given a few lines spoken by the same character, can you find her Kuchiguse?

Input Specification:

Each input file contains one test case. For each case, the first line is an integer N (2≤N≤100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character’s spoken line. The spoken lines are case sensitive.

Output Specification:

For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write nai.

Sample Input 1:

3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~

Sample Output 1:

nyan~

Sample Input 2:

3
Itai!
Ninjinnwaiyada T_T
T_T

Sample Output 2:

nai

作者 HOU, Qiming 单位 浙江大学

思路与总结

  • 一开始题目没看仔细,以为找最长子串,后来发现是找公共后缀,那么问题就简单许多了。

  • 不难想到可以将所有字符串反转再处理。

  • 对数组或容器的反转 可以用到algorithm.h里的 reverse: reverse(str.begin(), str.end() ) ;

  • 因为现在PAT不支持使用gets(),故用getline(cin,str)不然用字符数组得手搓一个。

#include<cstdio>
#include<string>
#include<algorithm>
#include<iostream>
using namespace std;
int n;
string str[260];
int ans=0;
int main(){
	int Minlen = 999;  //所有字符串里头最短的长度
	scanf("%d",&n);
	getchar();		//吸收回车
	for(int i=0; i<n; i++){
		getline(cin,str[i]);
		reverse(str[i].begin(), str[i].end());  //字符串反转
		if(str[i].size()< Minlen){
			Minlen = str[i].length();		//更新Minlen
		}
	}

	bool flag = true;
	for(int i=0; i<Minlen; i++ ){
		char temp = str[0][i];   //以0号字符串为对照
		for(int j=0; j<n; j++){		//比较所有字符串同位置的字符,看是否相同
			if(str[j][i]!=temp){	
				flag = false;
				break;
			}
		}
		if(flag){
			ans++;
		}
		else{
			break;
		}

	}
	if(ans > 0){
		for(int i=ans-1; i>=0; i--){
			printf("%c",str[0][i] );
		}
	}
	else{
		printf("nai");
	}

	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值