【PAT】A1050 String Subtraction (20分)--字符(串)hash

3 篇文章 0 订阅
3 篇文章 0 订阅

1050 String Subtraction (20分)

-----题目地址-----
Given two strings S1 and S2, S=S1−S​2 is defined to be the remaining string after taking all the characters in S​2 from S​1. Your task is simply to calculate S1 −S2 for any given strings. However, it might not be that simple to do it fast.

Input Specification:

Each input file contains one test case. Each case consists of two lines which gives S​1and S​2 , respectively. The string lengths of both strings are no more than 10^​4​​ . It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

Output Specification:

For each test case, print S1 − S​2​​ in one line.

Sample Input:

They are students.
aeiou

Sample Output:

Thy r stdnts.

作者 CHEN, Yue 单位 浙江大学

思路总结:

直接对字符串做删除操作显然有点麻烦,实际可以用散列的思想使问题得到简化。
①做散列表bool H[200] ,初始状态均为false
②遍历字符串2 : str, 对字符串2中的每个字符str[i],令H[str[i]-'\0'] = true (直接写H[str[i]] = true也没问题),表示该字符出现过。
③遍历字符串1: all, 对all中每个字符, 若该字符在散列表H中未出现也即false, 则输出,反之不输出。

AC代码:

#include<cstdio>
#include<cstring>
#include<string>
#include<iostream>
using namespace std;

string all, str;
bool H[200] = {false};
int main()
{
    getline(cin, all);
    getline(cin,str);

    for(int i=0; i<str.length(); i++){
        int key = str[i] - '\0';
        H[key] = true;
    }
    for(int i=0; i<all.length(); i++){
        int key = all[i] - '\0';
        if(H[key] == false){
            printf("%c",all[i]);
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值