PAT 1146 Topological Order拓扑排序

54 篇文章 1 订阅

原文链接:我的个人博客

题目描述

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:

Print in a line all the indices of queries which correspond to “NOT a topological order”. The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:

6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6

Sample Output:

3 4

考点

  图论,拓扑排序

思路

  题目给定一个序列,需要你判断是否为拓扑序列。在做这个题目时,最好先百度一下什么是拓扑序列。为了实现拓扑序列,每次选择入度为0的点进行输出,再将与该点相邻的顶点的入度数减一。
如何使用邻接矩阵会超时

代码

#include <bits/stdc++.h>
using namespace std;
vector<int> v[1010];
int in[1010];
int n,m,k;
 
int main(){
    scanf("%d%d",&n,&m);
    for(int i=0;i<m;i++){
        int a,b;
        scanf("%d%d",&a,&b);//a->b 
        v[a].push_back(b);//记录与a相邻的边
        in[b]++;//记录顶点b的入度 
    }
    scanf("%d",&k);
    vector<int>ans;
    for(int i=0;i<k;i++){
        int flag = 0;
        vector<int> tin(in,in+1010);
        for(int j=0;j<n;j++){
            int tmp;
            scanf("%d",&tmp);
            if(tin[tmp]!=0){//入度非0,即不是拓扑排序 
                flag = 1;
            }
            for(int t=0;t<v[tmp].size();t++){
                tin[v[tmp][t]]--;//所有与tmp相连接的顶点入度减一 
            }   
        }
        if(flag){//不是拓扑序列 
            ans.push_back(i);
        }
    }
    for(int i=0;i<ans.size();i++){
        cout<<ans[i];
        if(i!=ans.size()-1) cout<<" ";
    }
    cout<<endl;
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值