(PAT 1146) Topological Order (拓扑排序)

This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

gre.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:

Print in a line all the indices of queries which correspond to "NOT a topological order". The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:

6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6

Sample Output:

3 4

解题思路:

该题根据拓扑排序的性质去做,拓扑排序的性质见 https://blog.csdn.net/alex1997222/article/details/87299967

根据读入的序列,首先判断头顶点入度数是否为0,如果不是,那么这个序列肯定不是拓扑序列,然后将元素的邻接顶点入度数-1,判断序列中下一个结点,如果该结点的入度数不为0,那么这个序列就不是拓扑序列,依次循环

#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <string.h>
using namespace std;
const int MAXN = 1010;
vector<int> TEdges[MAXN];
int N, M, K;
int inDegrees[MAXN] = { 0 };
int tempIndegress[MAXN] = { 0 };
int main() {
	vector<int> notTopology;
	scanf("%d %d", &N, &M);
	int node1, node2;
	for (int i = 0; i < M; ++i) {
		scanf("%d %d", &node1, &node2);
		TEdges[node1].push_back(node2);
		inDegrees[node2]++;
	}
	scanf("%d", &K);
	int cnode;
	for (int i = 0; i < K; ++i) {
		memcpy(tempIndegress, inDegrees, sizeof(inDegrees));
		vector<int> squence;
		for (int j = 0; j < N; ++j) {
			scanf("%d", &cnode);
			squence.push_back(cnode);
		}
		for (int v = 0; v < squence.size()-1; ++v) {
			if (tempIndegress[squence[v]] != 0) {
				notTopology.push_back(i);
				break;
			}
			for (int adj_vertex : TEdges[squence[v]]) {
				tempIndegress[adj_vertex]--;
			}
			if (tempIndegress[squence[v + 1]] != 0) {
				notTopology.push_back(i);
				break;
			}
		}
	}
	for (int i = 0; i < notTopology.size(); ++i) {
		printf("%d", notTopology[i]);
		if (i < notTopology.size() - 1) printf(" ");
	}

	system("PAUSE");
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值