HDU_2579_Dating with girls(2) (BFS)

Dating with girls(2)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2229    Accepted Submission(s): 638



Problem Description
If you have solved the problem Dating with girls(1).I think you can solve this problem too.This problem is also about dating with girls. Now you are in a maze and the girl you want to date with is also in the maze.If you can find the girl, then you can date with the girl.Else the girl will date with other boys. What a pity!
The Maze is very strange. There are many stones in the maze. The stone will disappear at time t if t is a multiple of k(2<= k <= 10), on the other time , stones will be still there.
There are only ‘.’ or ‘#’, ’Y’, ’G’ on the map of the maze. ’.’ indicates the blank which you can move on, ‘#’ indicates stones. ’Y’ indicates the your location. ‘G’ indicates the girl's location . There is only one ‘Y’ and one ‘G’. Every seconds you can move left, right, up or down.
 

Input
The first line contain an integer T. Then T cases followed. Each case begins with three integers r and c (1 <= r , c <= 100), and k(2 <=k <= 10).
The next r line is the map’s description.
 

Output
For each cases, if you can find the girl, output the least time in seconds, else output "Please give me another chance!".
 

Sample Input
  
  
1 6 6 2 ...Y.. ...#.. .#.... ...#.. ...#.. ..#G#.
 

Sample Output
  
  
7
 

Source
 
分析:这道题貌似被我搁置了很久没有理,回想了一下原因好像是因为当时wa了n发还是过不了但是觉得自己的方法没什么问题。现在重新看这个题目感觉没有一点印象了。
           总体来说这个题目就是在一般的宽搜上多了一点就是墙壁会周期性(k)地消失,所以可以在标记数组增加一维,来表示step%k,因为在同一点余数不同,影响也不同。
题目链接: http://acm.hdu.edu.cn/showproblem.php?pid=2579
代码清单:
#include<map>
#include<queue>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long ll;
const int MAX = 105 ;

struct edge{ int x,y,step; };
int xy[4][2]={{0,-1},{-1,0},{0,1},{1,0}};
int T,r,c,k,sx,sy,ex,ey;
char str[MAX][MAX];
int vis[MAX][MAX][15];

bool check(edge v){
    if(v.x>=0&&v.x<r&&v.y>=0&&v.y<c&&!vis[v.x][v.y][v.step%k]){
        if(str[v.x][v.y]!='#')
            return true;
        if(str[v.x][v.y]=='#'&&v.step%k==0)
            return true;
    }
    return false;
}

void bfs(){
    queue<edge>q;
    while(q.size()) q.pop();
    memset(vis,0,sizeof(vis));
    edge p,w;
    p.x=sx;p.y=sy;p.step=0;
    vis[p.x][p.y][p.step%k]=1;
    q.push(p);
    while(q.size()){
        p=q.front();q.pop();
        if(p.x==ex&&p.y==ey){
            printf("%d\n",p.step);
            return ;
        }
        for(int i=0;i<4;i++){
            w.x=p.x+xy[i][0];
            w.y=p.y+xy[i][1];
            w.step=p.step+1;
            if(check(w)){
                vis[w.x][w.y][w.step%k]=1;
                q.push(w);
            }
        }
    }
    printf("Please give me another chance!\n");
}

int main(){
    scanf("%d",&T);
    while(T--){
        scanf("%d%d%d",&r,&c,&k);
        for(int i=0;i<r;i++){
            scanf("%s",str[i]);
            for(int j=0;j<c;j++){
                if(str[i][j]=='Y'){ sx=i;sy=j; }
                if(str[i][j]=='G'){ ex=i;ey=j; }
            }
        }
        bfs();
    }return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值