HDU2579 Dating with girls(2) BFS

题目:

Dating with girls(2)

If you have solved the problem Dating with girls(1).I think you can solve this problem too.This problem is also about dating with girls. Now you are in a maze and the girl you want to date with is also in the maze.If you can find the girl, then you can date with the girl.Else the girl will date with other boys. What a pity!
The Maze is very strange. There are many stones in the maze. The stone will disappear at time t if t is a multiple of k(2<= k <= 10), on the other time , stones will be still there.
There are only ‘.’ or ‘#’, ’Y’, ’G’ on the map of the maze. ’.’ indicates the blank which you can move on, ‘#’ indicates stones. ’Y’ indicates the your location. ‘G’ indicates the girl’s location . There is only one ‘Y’ and one ‘G’. Every seconds you can move left, right, up or down.

Input
The first line contain an integer T. Then T cases followed. Each case begins with three integers r and c (1 <= r , c <= 100), and k(2 <=k <= 10).
The next r line is the map’s description.

Output
For each cases, if you can find the girl, output the least time in seconds, else output “Please give me another chance!”.

Sample Input
1
6 6 2
…Y..
…#..
.#….
…#..
…#..
..#G#.

Sample Output
7

题意:
从Y走到G,地图上有每k秒就消失的墙#,问最少需要多久才能走到G处,若走不到输出Y

思路:
每个点有k个状态,为什么这么说呢?在某个点,只能在k秒内停留,若大于k秒就重复了,如果小于等于k秒都不能走出这个点那么就走不到G处,此外,某个点k种状态中的某一个状态被走过了,就不需要再走了。

代码:

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <queue>

using namespace std;

struct node
{
    int x, y, t;
};

const int maxn = 125;
const int dx[4] = {0, 0, -1, 1};
const int dy[4] = {1, -1, 0, 0};
int t, r, c, k;
node boy;
char tu[maxn][maxn];
bool vis[maxn][maxn][15];

void bfs(){
    queue<node> q;
    q.push(boy);
    vis[boy.x][boy.y][0] = true;
    while(!q.empty()){
        node tmp = q.front(); q.pop();
        if(tu[tmp.x][tmp.y] == 'G') {cout<<tmp.t<<endl; return;}
        for(int i=0; i<4; i++){
            int now_x = tmp.x + dx[i];
            int now_y = tmp.y + dy[i];
            int now_t = tmp.t + 1;
            if(0<=now_x && now_x<r && 0<=now_y && now_y<c){
                if((tu[now_x][now_y]!='#'|| now_t%k==0) && !vis[now_x][now_y][now_t%k]){
                    q.push(node{now_x, now_y, now_t});
                    vis[now_x][now_y][now_t%k] = true;
                }
            }
        }
    }
    cout<<"Please give me another chance!"<<endl;
}


int main(){
    //freopen("input.txt", "r", stdin);
    //freopen("output.txt", "w", stdout);
    cin>>t;
    while(t--){
        cin>>r>>c>>k;
        memset(tu, 0, sizeof(tu));
        memset(vis, false, sizeof(vis));
        for(int i=0; i<r; i++)
            for(int j=0; j<c; j++){
                cin>>tu[i][j];
                if(tu[i][j]=='Y'){
                    boy.x = i;
                    boy.y = j;
                    boy.t = 0;
                }
            }
        bfs();
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值