hdu 3729

Twin Prime Conjecture
Time Limit: 1000msMemory Limit: 32768KB This problem will be judged on HDU. Original ID: 3792
64-bit integer IO format: %I64d Java class name: Main
Prev Submit Status Statistics Next
Type:
None

Tag it!
If we define dn as: dn = pn+1-pn, where pi is the i-th prime. It is easy to see that d1 = 1 and dn=even for n>1. Twin Prime Conjecture states that “There are infinite consecutive primes differing by 2”.
Now given any positive integer N (< 10^5), you are supposed to count the number of twin primes which are no greater than N.
Input
Your program must read test cases from standard input.
The input file consists of several test cases. Each case occupies a line which contains one integer N. The input is finished by a negative N.
Output
For each test case, your program must output to standard output. Print in one line the number of twin primes which are no greater than N.
Sample Input
1
5
20
-2
Sample Output
0
1
4

无脑打表

#include<cstdio>
#include<cmath>
#include<iostream>
int num[(int)1e5+10]={0,0,1};
int ans[(int)1e5+10]={0};
    using namespace std;
int main()
{
    for(int i=3;i<=1e5;i++)
    {
        num[i++]=1;
        num[i]=0;
    }
    for(int i=3;i<=1e5;i++)
        for(int j=i+i;j<=1e5;j+=i)
        num[j]=0;
    int kk=0;
    for(int i=3;i<1e5;i++)
    {
        if(num[i])
        {
            for(int j=1;j<i;j++)
            {
                if(num[i-j])
                {
                    if(j==2)
                        kk++;
                    break;
                }

            }
            ans[i]=kk;
        }
        else
        ans[i]=kk;
    }


    //  cout<<ss[0]<<endl;
    int n;
    while(cin>>n)
    {
        if(n<0)
        break;
        if(n==1)
        puts("0");
        else
        {
            cout<<ans[n]<<endl;
        }
    }
    return 0;
 } 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值