poj_3301_三分_凹函数_求能覆盖N个点的最小正方形_对坐标系旋转_求新坐标

Texas Trip

After a day trip with his friend Dick, Harry noticed a strange pattern of tiny holes in the door of his SUV. The local American Tire store sells fiberglass patching material only in square sheets. What is the smallest patch that Harry needs to fix his door?

Assume that the holes are points on the integer lattice in the plane. Your job is to find the area of the smallest square that will cover all the holes.

Input

The first line of input contains a single integer T expressed in decimal with no leading zeroes, denoting the number of test cases to follow. The subsequent lines of input describe the test cases.

Each test case begins with a single line, containing a single integer n expressed in decimal with no leading zeroes, the number of points to follow; each of the following n lines contains two integers x and y, both expressed in decimal with no leading zeroes, giving the coordinates of one of your points.

You are guaranteed that T ≤ 30 and that no data set contains more than 30 points. All points in each data set will be no more than 500 units away from (0,0).

Output

Print, on a single line with two decimal places of precision, the area of the smallest square containing all of your points.

Sample Input

2
4
-1 -1
1 -1
1 1
-1 1
4
10 1
10 -1
-10 1
-10 -1
Sample Output

4.00
242.00
Source

Waterloo Local Contest, 2007.7.14

题意:给你n个点求能覆盖所有点的最小正方形

草稿记录 自己推一下

这里写图片描述
思路:
求出旋转后的最大和最小的点 ,就是可以求出旋转后的新坐标.

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
#define pi acos(-1.0)
#define eps 1e-8
const int inf=999999999;
double x[511],y[511];
int n;
double val(double tt)
{
    double mx=-inf,my=-inf,nx=inf,ny=inf;
    for(int i=0;i<n;i++)
    {
        double tx=x[i]*cos(tt)-y[i]*sin(tt);
        double ty=x[i]*sin(tt)+y[i]*cos(tt);
        mx=max(mx,tx);
        nx=min(nx,tx);
        my=max(my,ty);
        ny=min(ny,ty);
    }
    return max((mx-nx),(my-ny));
}
double solve(double l,double r )
{
    while(r-l>eps )
    {
        double ll=(r+l)/2.0;
        double rr=(ll+r)/2.0;
        if(val(ll)>val(rr))
            l=ll;
        else r=rr;
    }
    return val(l);
}
int main()
{

   int t,i,j;
   while(cin>>t)
   {
       while(t--)
       {
         scanf("%d",&n);
           for(i=0;i<n;i++)
            scanf("%lf%lf",&x[i],&y[i]);
           double l=0.0,r=pi/2.0;
           double ans=solve(l,r);
           printf("%.2lf\n",ans*ans);
       }
   }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值