poj_1845_ 求所有a^b的所有因子和

Sumdiv

Consider two natural numbers A and B. Let S be the sum of all natural divisors of A^B. Determine S modulo 9901 (the rest of the division of S by 9901).
Input
The only line contains the two natural numbers A and B, (0 <= A,B <= 50000000)separated by blanks.
Output
The only line of the output will contain S modulo 9901.
Sample Input
2 3
Sample Output
15
Hint
2^3 = 8.
The natural divisors of 8 are: 1,2,4,8. Their sum is 15.
15 modulo 9901 is 15 (that should be output).

题意:
求所有a^b的所有因子和
基本知识:
任何人一个数都可以分解为素数幂次方相乘:
a=(p1^k1)*(p2^k2)………;
p是素数,k是这个数最多能被除几次;
因子个数就是:
(1+2+……..k1)*(1+2+……….k2)……….
那么 因子和就是
(1+p1^1+…..p1^k1)*(1+p2^2+…..p2^k2)……………..;
a^b=(p1^k1*b)*(p2^k2*b)…..;
1+p1^1+…..p1^k1这就是一个等比数列 分奇偶讨论 提通项 减少次方数求解;
自己提一下

#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
typedef long long ll;
const ll mod=9901;
ll solve(ll a,ll b)
{
    ll ans=1;
    a%=mod;
    while(b)
    {
        if(b&1) ans=ans*a%mod;
        a=a*a%mod;
        b>>=1;
    }
    return ans%mod;
}
ll sum(ll a,ll n)
{
    if(!n) return 1;
    else if(n&1) return sum(a,n/2)*(1+solve(a,n/2+1))%mod;
    else  return sum(a,n/2-1)*(1+solve(a,n/2+1))%mod+solve(a,n/2)%mod;
}
int main()
{
    ll a,b,i,j;
    while(cin>>a>>b)
    {
        if(b==0||a<=1)
        {
            puts("1");
            continue;
        }
        ll ans=1;
        ll n=(ll)sqrt(a+0.5);
        for(i=2; i<=n; i++)
        {
            if(a%i==0)
            {
                ll cnt=0;
                while(a%i==0)
                {
                    cnt++;
                    a/=i;
                }
                ans=ans*sum(i,cnt*b)%mod;
            }

        }
        if(a>1)
            ans=ans*sum(a,b)%mod;
        cout<<ans<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值