zoj_3822_概率dp入门

Edward is the headmaster of Marjar University. He is enthusiastic about chess and often plays chess with his friends. What’s more, he bought a large decorative chessboard with N rows and M columns.

Every day after work, Edward will place a chess piece on a random empty cell. A few days later, he found the chessboard was dominated by the chess pieces. That means there is at least one chess piece in every row. Also, there is at least one chess piece in every column.

“That’s interesting!” Edward said. He wants to know the expectation number of days to make an empty chessboard of N × M dominated. Please write a program to help him.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There are only two integers N and M (1 <= N, M <= 50).

Output

For each test case, output the expectation number of days.

Any solution with a relative or absolute error of at most 10-8 will be accepted.

Sample Input

2
1 3
2 2
Sample Output

3.000000000000
2.666666666667
Source
The 2014 ACM-ICPC Asia Mudanjiang Regional Contest

mean
第一行输入t 代表有t案例
接下来t行每行n ,m 代表有棋盘长宽,

每天可以在一个空位放置一枚棋子 问你 ,每行每列都至少有一个棋子的天数期望

ans
对每个点递推放的棋子数

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
double dp[55][55][55 * 55] = { 0 };
int main()
{
    int t, n, m, i, j;
    while (cin >> t)
    {
        while (t--)
        {
            scanf("%d%d", &n, &m);
            memset(dp, 0, sizeof(dp));
            dp[0][0][0] = 1;
            int cnt = n*m;
            for (i = 1; i <= n; i++)
            {
                for (j = 1; j <= m; j++)
                {
                    for (int k = 1; k <= cnt; k++)
                    {
                        int set = cnt - k + 1;
                        //if (i*j <= k - 1)
                            dp[i][j][k] += dp[i][j][k - 1] * (1.0*(i*j - k + 1)) / set;
                        dp[i][j][k] += dp[i - 1][j][k - 1] * (1.0*(n - i + 1)*j) / set +
                            dp[i][j - 1][k - 1] * (1.0*(m - j + 1)*i) / set +
                            dp[i - 1][j - 1][k - 1] * (1.0*(n - i + 1)*(m - j + 1)) / set;
                    }
                }
            }
            double ans = 0;
            for (i = 1; i <= cnt; i++)
                ans += i*(dp[n][m][i] - dp[n][m][i - 1]);
            printf("%.8lf\n", ans);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值