题目链接:传送门
Area
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 20249 | Accepted: 5517 |
Description
You are going to compute the area of a special kind of polygon. One vertex of the polygon is the origin of the orthogonal coordinate system. From this vertex, you may go step by step to the following vertexes of the polygon until back to the initial vertex. For each step you may go North, West, South or East with step length of 1 unit, or go Northwest, Northeast, Southwest or Southeast with step length of square root of 2.
For example, this is a legal polygon to be computed and its area is 2.5:
For example, this is a legal polygon to be computed and its area is 2.5:
Input
The first line of input is an integer t (1 <= t <= 20), the number of the test polygons. Each of the following lines contains a string composed of digits 1-9 describing how the polygon is formed by walking from the origin. Here 8, 2, 6 and 4 represent North, South, East and West, while 9, 7, 3 and 1 denote Northeast, Northwest, Southeast and Southwest respectively. Number 5 only appears at the end of the sequence indicating the stop of walking. You may assume that the input polygon is valid which means that the endpoint is always the start point and the sides of the polygon are not cross to each other.Each line may contain up to 1000000 digits.
Output
For each polygon, print its area on a single line.
Sample Input
4 5 825 6725 6244865
Sample Output
0 0 0.5 2
解题思路:求多边形面积
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <string>
#include <stack>
#include <queue>
using namespace std;
typedef long long ll;
const int N = 1000900;
const int M = 1000;
const int INF = 0x3fffffff;
const double eps = 1e-8;
const double PI = acos(-1.0);
struct Point
{
int x,y;
Point(){}
Point(int _x,int _y){
x = _x; y = _y;
}
int operator ^ (const Point&a)const{
return a.x*y-a.y*x;
}
};
//计算多边形面积,点的编号从0~n-1
ll CalcArea(Point p[],int n)
{
ll res = 0;
for( int i = 0 ; i < n ; ++i ){
res += (p[i]^p[(i+1)%n]);
}
return fabs(res);
}
Point point[N];
int main()
{
int T;
cin >> T;
while( T-- ){
int sx = 0,sy = 0;
string st;
cin >> st;
int len = st.length();
for( int i = 0 ; i < len-1 ; ++i ){
switch(st[i]){
case '8':sy += 1;break;
case '2':sy -= 1;break;
case '6':sx += 1;break;
case '4':sx -= 1;break;
case '9':sx += 1,sy += 1;break;
case '7':sx -= 1,sy += 1;break;
case '3':sx += 1,sy -= 1;break;
case '1':sx -= 1,sy -= 1;break;
}
point[i] = Point(sx,sy);
}
point[len-1] = Point(0,0);
ll ans = CalcArea(point,len);
if( ans%2 == 0 ){
printf("%lld\n",ans/2);
}else{
printf("%lld.5\n",ans/2);
}
}
return 0;
}