PTA(原PAT) 甲级1015 Reversible Primes

1015 Reversible Primes (20 分)
A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<105 ) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:
The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:
For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No

代码如下:

#include <iostream>

using namespace std;
int prime[10000];
int my_reverse(int n,int d)
{
    int s = n,m,r = 0;
    while(s != 0)
    {
        m = s % d;
        s = s / d;
        r += m;
        if(s != 0)
            r *= d;
    }
    return r;
}

bool is_prime(int n,int con)
{
    if(n == 1)
        return false;
    else
    {
        int k = n / 2 + 1;
        for(int i = 0; k > prime[i] && i != con; ++i)
        {
            if(n % prime[i] == 0)
                return false;
        }
    }
    return true;
}
int main()
{
    /*找出10000以内的所有质数*/
    prime[0] = 2;
    int con = 1,j;
    for(int i = 3; i != 20001; i += 2)
    {
        for(j = 0; j != con; ++j)
        {
            if(i % prime[j] == 0)
                break;
        }
        if(j == con)
            prime[con++] = i;
    }
    int n,d,r;
    cin >> n;
    while(n > 0)
    {
        cin >> d;
        if(is_prime(n,con))
        {
            r = my_reverse(n,d);
            if(is_prime(r,con))
                cout << "Yes" << '\n';
            else
                cout << "No" << '\n';
        }
        else
            cout << "No" << '\n';
        cin >> n;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值