HDU 6168 Numbers

Numbers

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 289 Accepted Submission(s): 148

Problem Description
zk has n numbers a1,a2,…,an. For each (i,j) satisfying 1i<jn, zk generates a new number (ai+aj). These new numbers could make up a new sequence b1,b2,…,bn(n−1)/2.
LsF wants to make some trouble. While zk is sleeping, Lsf mixed up sequence a and b with random order so that zk can’t figure out which numbers were in a or b. “I’m angry!”, says zk.
Can you help zk find out which n numbers were originally in a?

Input
Multiple test cases(not exceed 10).
For each test case:
·The first line is an integer m(0≤m≤125250), indicating the total length of a and b. It’s guaranteed m can be formed as n(n+1)/2.
·The second line contains m numbers, indicating the mixed sequence of a and b.
Each ai is in [1,10^9]

Output
For each test case, output two lines.
The first line is an integer n, indicating the length of sequence a;
The second line should contain n space-seprated integers a1,a2,…,an(a1≤a2≤…≤an). These are numbers in sequence a.
It’s guaranteed that there is only one solution for each case.

Sample Input
6
2 2 2 4 4 4
21
1 2 3 3 4 4 5 5 5 6 6 6 7 7 7 8 8 9 9 10 11

Sample Output
3
2 2 2
6
1 2 3 4 5 6

Source
2017 Multi-University Training Contest - Team 9


题意:
给一个序列a,对应地有序列b为a的第i,j项的和。现在把a和b混在一起,总的长度为m,求原来的序列a。

思路:
题目中已经给了m=n(n-1)/2,显然 n=2m 。然后对这个序列进行排序,最小的两项就是a1,a2。删掉a1,a2,a1+a2,最小的就是a3。删掉a3,a3+a1,a3+a2,最小的就是a4。以此类推。
一开始我的思路是对了,但是拿数组写的,然后TLE了。后来用了vector也TLE,网上说vector的push_back和erase复杂度有点高,果然木有错。改用multiset之后就A了。

代码:

#include<stdio.h>
#include<math.h>
#include<iostream>
#include<algorithm>
#include<set>
#define ll long long
#define maxn 125255
using namespace std;
multiset<ll> q;
multiset<ll> a;
ll m,n;
int main()
{
    while(~scanf("%lld",&m))
    {
        n=sqrt(2*m);
        ll i,j;
        for(i=0;i<m;i++)
        {
            ll x;
            scanf("%lld",&x);
            q.insert(x);
        }
        printf("%lld\n",n);
        a.insert(*(q.begin()));
        q.erase(q.begin());
        a.insert(*(q.begin()));
        q.erase(q.begin());
        ll step=1;
        multiset<ll>::iterator itor;
        while(a.size()<n)
        {
            for(itor=a.begin();itor!=(--a.end());itor++)
            {
                q.erase(q.find(*itor+*(--a.end())));
            }
            a.insert(*(q.begin()));
            q.erase(q.begin());
        }
        for(itor=a.begin();itor!=a.end();itor++)
        {
            printf("%lld",*itor);
            if(itor!=(--a.end())) printf(" ");
        }
        printf("\n");
        q.clear();
        a.clear();
    }
}

P.S. 我仿佛已经看见公式灵魂漂移的样子了,过段时间自己建站吧 QAQ

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值