HDU 6216 A Cubic number and A Cubic Number

A Cubic number and A Cubic Number

Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 160 Accepted Submission(s): 99

Problem Description
A cubic number is the result of using a whole number in a multiplication three times. For example, 3×3×3=27 so 27 is a cubic number. The first few cubic numbers are 1,8,27,64 and 125. Given an prime number p. Check that if p is a difference of two cubic numbers.

Input
The first of input contains an integer T (1≤T≤100) which is the total number of test cases.
For each test case, a line contains a prime number p (2≤p≤1012).

Output
For each test case, output ‘YES’ if given p is a difference of two cubic numbers, or ‘NO’ if not.

Sample Input
10
2
3
5
7
11
13
17
19
23
29

Sample Output
NO
NO
NO
YES
NO
NO
NO
YES
NO
NO

Source
2017 ACM/ICPC Asia Regional Qingdao Online


题意:
给一个质数,问是否为两个立方数的差。

思路:
青岛网络赛的签到题,我可能是活在梦里吧。
Cuban Prime:只有相邻两个立方数的差可能为质数。
由于题目给的一定是质数,所以只要打相邻立方数的差的表就行了……
我今天都干了些啥啊……

代码:

#include<bits/stdc++.h>
#define maxn 1000000
#define ll long long
using namespace std;
ll ans[maxn];
void init()
{
    ll i,cnt=0;
    for(i=2;i<maxn;i++)
    {
        ans[cnt++]=i*i*i-(i-1)*(i-1)*(i-1);
    }
}
int main()
{
    init();
    int t;
    scanf("%d",&t);
    while(t--)
    {
        ll p;
        scanf("%lld",&p);
        int i;
        int flag=0;
        for(i=0;i<999997;i++)
        {
            if(p==ans[i])
            {
                flag=1;
                break;
            }
            if(p<ans[i]) break;
        }
        if(flag) printf("YES\n");
        else printf("NO\n");
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值