1011 A Cubic number and A Cubic Number

Problem Description

A cubic number is the result of using a whole number in a
multiplication three times. For example, 3×3×3=27 so 27 is a cubic
number. The first few cubic numbers are 1,8,27,64 and 125. Given an
prime number p. Check that if p is a difference of two cubic numbers.

Input

The first of input contains an integer T (1≤T≤100) which is the total
number of test cases. For each test case, a line contains a prime
number p (2≤p≤10^12).

Output

For each test case, output ‘YES’ if given p is a difference of two
cubic numbers, or ‘NO’ if not.

Sample Input

10
2
3
5
7
11
13
17
19
23
29

Sample Output

NO
NO
NO
YES
NO
NO
NO
YES
NO
NO

题意:给出一个素数,看这个素数是否是两立方数之差。
x3-y3=(x-y)(x2+x*y+y2) 由素数的定义,在大于1的自然数中,除了1和它本身以外不再有其他因数,得x-y=1,即x=y+1;

因为素数的范围已知,所以就用了查找比较高效的二分查找。
大佬代码如下

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long ll;
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        ll p;
        scanf("%lld",&p);
        ll l=0,r=1000000;
        while(l<r)
        {
            ll m=(l+r)/2;
            if((m+1)*(m+1)*(m+1)-m*m*m<p)l=m+1;
            else r=m;
        }
        printf("%s\n",((l+1)*(l+1)*(l+1)-l*l*l==p ? "YES" : "NO"));
    }
    return 0;
}

#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#define ll long long
using namespace std;
const int maxn=1e6+10;
ll t,n;

int main(){
	
	scanf("%lld",&t);
	while(t--){
		scanf("%lld",&n);
		ll i=1;
		int flag=0;
		ll aaaa;
		while(i <= maxn){
			aaaa=3*i*i+3*i+1;
			if(aaaa == n){
				flag=1;
				break ;
			}
			i++;
			if(aaaa > n)
				break ;
		}
		if(flag)
			printf("YES\n");
		else
			printf("NO\n");
	}		
	
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值