HDU 5974 A Simple Math Problem

A Simple Math Problem

Given two positive integers a and b,find suitable X and Y to meet the conditions: X+Y=a Least Common Multiple (X, Y) =b

Input
Input includes multiple sets of test data.Each test data occupies one line,including two positive integers a(1≤a≤2*10^4),b(1≤b≤10^9),and their meanings are shown in the description.Contains most of the 12W test cases.

Output
For each set of input data,output a line of two integers, representing X, Y. If you cannot find such X and Y, output one line of “No Solution”(without quotation).

Sample Input

6 8
798 10780

Sample Output

No Solution
308 490


题意:
已知 X+Y=a , LCM(X,Y)=b ,求X、Y。

思路:

x+y=a
xy/gcd(x,y)=b

x/gcd(x,y)+y/gcd(x,y)=a/gcd(x,y)
(xy/gcd(x,y))/gcd(x,y)=b/gcd(x,y)

i=x/gcd(x,y) j=y/gcd(x,y) :
i+j=a/gcd(x,y)
ij=b/gcd(x,y)

gcd(x,y)=gcd(x+y,xy)=gcd(a,b)

i+j=a/gcd(a,b)
ij=b/gcd(a,b)

代码:

#include<bits/stdc++.h>
#define ll long long
using namespace std;
ll a,b;
int main()
{
    while(~scanf("%lld %lld",&a,&b))
    {
        int k;
        k=__gcd(a,b);
        int zz=a*a-4*k*b;
        if(zz<0) printf("No Solution\n");
        else
        {
            int ans1=(int)(a-sqrt((double)zz))/2;
            int ans2=(int)(a+sqrt((double)zz))/2;
            if(ans1+ans2==a&&(ans1*ans2/__gcd(ans1,ans2))==b)
                printf("%d %d\n",ans1,ans2);
            else printf("No Solution\n");
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值