HDU 1170 Balloon Comes!

Problem Description

The contest starts now! How excited it is to see balloons floating around. You, one of the best programmers in HDU, can get a very beautiful balloon if only you have solved the very very very… easy problem.
Give you an operator (+,-,*, / –denoting addition, subtraction, multiplication, division respectively) and two positive integers, your task is to output the result.
Is it very easy?
Come on, guy! PLMM will send you a beautiful Balloon right now!
Good Luck!

Input

Input contains multiple test cases. The first line of the input is a single integer T (0

Output

For each case, print the operation result. The result should be rounded to 2 decimal places If and only if it is not an integer.

Sample Input

4
+ 1 2
- 1 2
* 1 2
/ 1 2

Sample Output

3
-1
2
0.50

题目大意:

先输入一个数,表示接下来有几组测试数据。测试数据会给你一个操作符(+,,,/ -表示加法,减法,乘法,除法)和两个正整数,你的任务是输出结果。

c++

#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
    char a;
    int b,c,d;
    double e,f;
    cin>>b;
    while(b--)
    {
        cin>>a>>c>>d;
        if(a=='+')      //判断操作符是什么
        {
            e=c+d;
            printf("%.0lf\n",e);
        }
        else if(a=='-')
        {
            e=c-d;
            printf("%.0lf\n",e);
        }
        else if(a=='*')
        {
            e=c*d;
            printf("%.0lf\n",e);
        }
        else
        {
            e=c*1.0/d;
            if(c%d==0)
            {
                printf("%.0lf\n",e);
            }
            else
            {
                printf("%.2lf\n",e);
            }
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值