HDU 6124 Euler theorem

Problem Description

HazelFan is given two positive integers a,b, and he wants to calculate amodb. But now he forgets the value of b and only remember the value of a, please tell him the number of different possible results.

Input

The first line contains a positive integer T(1≤T≤5), denoting the number of test cases. 
For each test case: 
A single line contains a positive integer a(1≤a≤109).

Output

For each test case: 
A single line contains a nonnegative integer, denoting the answer.

Sample Input



3

Sample Output


3

题目大意:

输入一个数n,有n组测试数据,输入A,求A%B有几种可能,B可以为任意值。 
这是一个规律题,可以先用暴力求出正确答案,再观察规律。这道题的规律是 
d=(b-1)/2+2或d=(b+1)/2+1。d为结果,b为输入值

c++

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
    long long int a,b,c,d,e,f;
    cin>>a;
    while(a--)
    {
        cin>>b;
        d=(b-1)/2+2;
        cout<<d<<endl;
    }
    return 0;
}




  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值