NYOJ 26 A problem is easy

Problem Description

When Teddy was a child , he was always thinking about some simple math problems ,such as “What it’s 1 cup of water plus 1 pile of dough ..” , “100 yuan buy 100 pig” .etc..

这里写图片描述

One day Teddy met a old man in his dream , in that dream the man whose name was“RuLai” gave Teddy a problem :

Given an N , can you calculate how many ways to write N as i * j + i + j (0 < i <= j) ?

Teddy found the answer when N was less than 10…but if N get bigger , he found it was too difficult for him to solve. 
Well , you clever ACMers ,could you help little Teddy to solve this problem and let him have a good dream ?

Input

The first line contain a T(T <= 2000) . followed by T lines ,each line contain an integer N (0<=N <= 10[sup]10[/sup]).

Output

For each case, output the number of ways in one line.

Sample Input



3

Sample Output


1

题目大意:

给出一个数n,求 i * j + i + j = n(0 < i <= j)有多少种方法。

#include<iostream>
#include<cmath>
#include<cstdio>
using namespace std;
int main()
{
    long long int a,b,c,d,e,f,m;
    cin>>a;
    while(a--)
    {
        cin>>m;
        m++;
        b=sqrt(m);
        e=0;
        for(c=2;c<=b;c++)
        {
            if(m%c==0&&m/c>=c)
                e++;
        }
        cout<<e<<endl;
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值