【PAT】1039 Course List for Student (25分)(模拟,STL map vector)

题目:

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤40,000), the number of students who look for their course lists, and K (≤2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students N​i​​ (≤200) are given in a line. Then in the next line, N​i​​ student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

 

题目大意:有一个表保存了学生的选课信息,根据学生姓名来查询信息,输出该名学生选课情况。

输入:N(学生总人数)K(课程总数)然后每一行是一个课程代码以及选课人数,下一行是该课程代码选了的人。

输出:按照输入最后一行的姓名 每行输出每个人的查询情况。

解题思路:用map<string,vector<int>>来保存选课列表。因为最后一个测试点数据很多,所以不能用cin cout,会超时。

代码:

#include<iostream>
#include<algorithm>
#include<map>
#include<vector>
#include<cstdio>
using namespace std;
int main(){
  map<string,vector<int>> ma;
  int n,k;
  //freopen("input.txt","r",stdin);
  //cin>>n>>k;
  scanf("%d%d",&n,&k);
  //string name;
  char name[5];
  int c,num;//课程号和学生人数
  for(int i=0;i<k;i++){
    //cin>>c>>num;
    scanf("%d%d",&c,&num);
    for(int j=0;j<num;j++){
      //cin>>name;
      scanf("%s",name);
      
      ma[name].push_back(c);
    }
  }
 
  for(int i=0;i<n;i++){
    //cin>>name;
    scanf("%s",name);
    sort(ma[name].begin(),ma[name].end());
    //cout<<name<<" "<<ma[name].size();
    printf("%s %d",name,ma[name].size());
    for(int j=0;j<ma[name].size();j++){
      printf(" %d",ma[name][j]);
      //cout<<" "<<ma[name][j];
    }cout<<endl;
		
  }
}

看到了柳神的优秀代码,膜一波:(真的没想到能用hash将学生姓名变成int)

https://www.liuchuo.net/archives/2145

#include <cstdio>
#include <vector>
#include <algorithm>
using namespace std;
int getid(char *name) {
    int id = 0;
    for(int i = 0; i < 3; i++)
        id = 26 * id + (name[i] - 'A');
    id = id * 10 + (name[3] - '0');
    return id;
}
const int maxn = 26 * 26 * 26 * 10 + 10;
vector<int> v[maxn];

int main() {
    int n, k, no, num, id = 0;
    char name[5];
    scanf("%d %d", &n, &k);
    for(int i = 0; i < k; i++) {
        scanf("%d %d", &no, &num);
        for(int j = 0; j < num; j++) {
            scanf("%s", name);
            id = getid(name);
            v[id].push_back(no);
        }
    }
    for(int i = 0; i < n; i++) {
        scanf("%s", name);
        id = getid(name);
        sort(v[id].begin(), v[id].end());
        printf("%s %lu", name, v[id].size());
        for(int j = 0; j < v[id].size(); j++)
            printf(" %d", v[id][j]);
        printf("\n");
    }
    return 0;
}

还有另一个大神,他的输入和我差不多,但是输出很优秀,也膜一波:

https://blog.csdn.net/a617976080/article/details/95863148

// 遍历输出结果
    vector<int> *v = NULL;
    for(int i = 0; i < N; i++){
        cin >> name;
        v = &data[name];
        // 输出每个学生的课程序号之前要排序
        sort(v->begin(), v->end());
        // 输出学生名称和课程总数
        printf("%s %ld", name.c_str(), v->size());
        // 输出课程序号
        for(auto lt = v->cbegin(); lt != v->cend(); lt++){
            printf(" %d", *lt);
        }
        putchar('\n');
    }
    return 0;
}
/*————————————————
版权声明:本文为CSDN博主「昵称五个字」的原创文章,遵循CC 4.0 BY-SA版权协议,转载请附上原文出处链接及本声明。
原文链接:https://blog.csdn.net/a617976080/article/details/95863148*/

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值