PAT甲级 1005 Spell It Right(C语言)测试点4通不过

题目:

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:
Each input file contains one test case. Each case occupies one line which contains an N (≤10​100​​).

Output Specification:
For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five

解题思路:

这题很简单,思路很明确:

  1. 读入n:由于n最多有一百位,可将n设置为有101位的字符串;
  2. 将n的各位数之和存入a中:a+=n[i] - ‘0’;
  3. 由于逐位输出的结果是a的逆序,所以需要先将a的逆序存入b中;
  4. 为了方便,将b设置为三位的字符串(100位数各位和最大为900)并初始化:b[3]={0};
  5. 将a从低位到高位取余存入b中;
  6. 由于存入b中的各位是a的逆序,所以从后往前逐位输出b中数字对应的英文。

明明是这么清晰简单的题目,我却有一个测试点4无论如何也过不去,求大神指点(卑微.jpg

目前已知的情报:

  • 输入0可以正确输出zero
  • 输入5555等使得a的低位为0的数也可以正确输出two zero

我想不出还有哪些特殊情况了,这个测试点4到底是什么神仙 test case QAQ
看了很多大神的答案也没找出我为什么卡住了。求个大佬来给小的指点迷津TAT
下面是我写的代码,估计是哪些细节实现上有问题,可我又看不出来。

代码:

#include <stdio.h>
#include <string.h>

int main(){
	char n[101];
	int a=0;
 	scanf("%s",&n);
	int i=0;
	for(i=0;i<strlen(n);i++){
  		a+=n[i]-'0';
 	}
 	char b[3]={0};
 	i=0;
 	do{
  		b[i++]='0'+a%10;
  		a/=10;
 	}while(a);
 	for(i=strlen(b)-1;i>=0;i--){
  		switch(b[i]){
   			case '0':printf("zero");break;
  			case '1':printf("one");break;
   			case '2':printf("two");break;
   			case '3':printf("three");break;
   			case '4':printf("four");break;
   			case '5':printf("five");break;
   			case '6':printf("six");break;
   			case '7':printf("seven");break;
   			case '8':printf("eight");break;
   			case '9':printf("nine");break;
  		}
  		if(i) printf(" ");
 	}
 	return 0;
 }
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值