Greedy Gift Givers
A group of NP (2 ≤ NP ≤ 10) uniquely named friends has decided to exchange gifts of money. Each of these friends might or might not give some money to any or all of the other friends. Likewise, each friend might or might not receive money from any or all of the other friends. Your goal in this problem is to deduce how much more money each person gives than they receive.
The rules for gift-giving are potentially different than you might expect. Each person sets aside a certain amount of money to give and divides this money evenly among all those to whom he or she is giving a gift. No fractional money is available, so dividing 3 among 2 friends would be 1 each for the friends with 1 left over -- that 1 left over stays in the giver's "account".
In any group of friends, some people are more giving than others (or at least may have more acquaintances) and some people have more money than others.
Given a group of friends, no one of whom has a name longer than 14 characters, the money each person in the group spends on gifts, and a (sub)list of friends to whom each person gives gifts, determine how much more (or less) each person in the group gives than they receive.
IMPORTANT NOTE
The grader machine is a Linux machine that uses standard Unix conventions: end of line is a single character often known as '\n'. This differs from Windows, which ends lines with two charcters, '\n' and '\r'. Do not let your program get trapped by this!
PROGRAM NAME: gift1
INPUT FORMAT
Line 1: | The single integer, NP | |||
Lines 2..NP+1: | Each line contains the name of a group member | |||
Lines NP+2..end: | NP groups of lines organized like this:
|
SAMPLE INPUT (file gift1.in)
5 dave laura owen vick amr dave 200 3 laura owen vick owen 500 1 dave amr 150 2 vick owen laura 0 2 amr vick vick 0 0
OUTPUT FORMAT
The output is NP lines, each with the name of a person followed by a single blank followed by the net gain or loss (final_money_value - initial_money_value) for that person. The names should be printed in the same order they appear on line 2 of the input.
All gifts are integers. Each person gives the same integer amount of money to each friend to whom any money is given, and gives as much as possible that meets this constraint. Any money not given is kept by the giver.
SAMPLE OUTPUT (file gift1.out)
dave 302 laura 66 owen -359 vick 141 amr -150
#include <iostream>
#include <fstream>
#include <string>
using namespace std;
struct Person{
string name;
int inital_money;
int final_money;
char lucky_list[10];
int lucky_num;
int give_money;
};
char getId(string* lucker,string &name)
{
for(char i=0;i<=10;i++)
if(lucker[i]==name)
return i;
return -1;
}
int main(int argc, const char * argv[])
{
ofstream fout("gift1.out");
ifstream fin("gift1.in");
int PN;
string luck_list[10];
Person p[10];
while(fin>>PN&&PN>=2&&PN<=10)
{
string str;
for(int i=0;i<PN;i++)fin>>luck_list[i];
for(int ip=0;ip<PN;ip++)
{
fin>>str;
char pos=getId(luck_list, str);
p[pos].name=str;
fin>>p[pos].inital_money>>p[pos].lucky_num;
if(p[pos].lucky_num)
p[pos].give_money=p[pos].inital_money/p[pos].lucky_num;
else
p[pos].give_money=0;
p[pos].final_money=p[pos].inital_money-p[pos].give_money*p[pos].lucky_num;
for(int io=0;io<p[pos].lucky_num;io++){fin>>str;p[pos].lucky_list[io]=getId(luck_list, str);}
}
for(int i=0;i<PN;i++)
{
for(int j=0;j<p[i].lucky_num;j++)
{
p[p[i].lucky_list[j]].final_money += p[i].give_money;
}
}
for(int i=0;i<PN;i++)
{fout<<p[i].name<<" "<<p[i].final_money-p[i].inital_money<<endl;}
}
return 0;
}
运行结果:
USER: jim zhai [jszhais1] TASK: gift1 LANG: C++ Compiling... Compile: OK Executing... Test 1: TEST OK [0.000 secs, 3360 KB] Test 2: TEST OK [0.000 secs, 3360 KB] Test 3: TEST OK [0.000 secs, 3360 KB] Test 4: TEST OK [0.000 secs, 3360 KB] Test 5: TEST OK [0.000 secs, 3360 KB] Test 6: TEST OK [0.000 secs, 3360 KB] Test 7: TEST OK [0.000 secs, 3360 KB] Test 8: TEST OK [0.000 secs, 3360 KB] Test 9: TEST OK [0.000 secs, 3360 KB] All tests OK.Your program ('gift1') produced all correct answers! This is your submission #2 for this problem. Congratulations!
the answer:
The hardest part about this problem is dealing with the strings representing people's names.
We keep an array of Person structures that contain their name and how much money they give/get.
The heart of the program is the lookup() function that, given a person's name, returns their Person structure. We add new people with addperson().
Note that we assume names are reasonably short.
#include <stdio.h> #include <string.h> #include <assert.h> #define MAXPEOPLE 10 #define NAMELEN 32 typedef struct Person Person; struct Person { char name[NAMELEN]; int total; }; Person people[MAXPEOPLE]; int npeople; void addperson(char *name) { assert(npeople < MAXPEOPLE); strcpy(people[npeople].name, name); npeople++; } Person* lookup(char *name) { int i; /* look for name in people table */ for(i=0; i<npeople; i++) if(strcmp(name, people[i].name) == 0) return &people[i]; assert(0); /* should have found name */ } int main(void) { char name[NAMELEN]; FILE *fin, *fout; int i, j, np, amt, ng; Person *giver, *receiver; fin = fopen("gift1.in", "r"); fout = fopen("gift1.out", "w"); fscanf(fin, "%d", &np); assert(np <= MAXPEOPLE); for(i=0; i<np; i++) { fscanf(fin, "%s", name); addperson(name); } /* process gift lines */ for(i=0; i<np; i++) { fscanf(fin, "%s %d %d", name, &amt, &ng); giver = lookup(name); for(j=0; j<ng; j++) { fscanf(fin, "%s", name); receiver = lookup(name); giver->total -= amt/ng; receiver->total += amt/ng; } } /* print gift totals */ for(i=0; i<np; i++) fprintf(fout, "%s %d\n", people[i].name, people[i].total); exit (0); }