Three farmers rise at 5 am each morning and head for the barn to milk three cows. The first farmer begins milking his cow at time 300 (measured in seconds after 5 am) and ends at time 1000. The second farmer begins at time 700 and ends at time 1200. The third farmer begins at time 1500 and ends at time 2100. The longest continuous time during which at least one farmer was milking a cow was 900 seconds (from 300 to 1200). The longest time no milking was done, between the beginning and the ending of all milking, was 300 seconds (1500 minus 1200).
Your job is to write a program that will examine a list of beginning and ending times for N (1 <= N <= 5000) farmers milking N cows and compute (in seconds):
- The longest time interval at least one cow was milked.
- The longest time interval (after milking starts) during which no cows were being milked.
PROGRAM NAME: milk2
INPUT FORMAT
Line 1: | The single integer |
Lines 2..N+1: | Two non-negative integers less than 1000000, the starting and ending time in seconds after 0500 |
SAMPLE INPUT (file milk2.in)
3 300 1000 700 1200 1500 2100
OUTPUT FORMAT
A single line with two integers that represent the longest continuous time of milking and the longest idle time.SAMPLE OUTPUT (file milk2.out)
900 300
/*
ID: jszhais1
PROG: milk2
LANG: C++
*/
#include <iostream>
#include "stdlib.h"
#include <fstream>
using namespace std;
struct WorkTime
{
int start;
int end;
};
int cmp ( const void *a , const void *b )
{ return (*(WorkTime *)a).start - (*(WorkTime *)b).start; }
int main(int argc, const char * argv[])
{
ofstream fout("milk2.out");
ifstream fin("milk2.in");
int length;
while(fin>>length){
WorkTime *time = new WorkTime[length];
for(int i=0;i<length;i++)
fin>>time[i].start>>time[i].end;
qsort(time,length,sizeof(time[0]),cmp);
int maxBusy = time[0].end - time[0].start,maxFree = 0;
for(int i = 1,start=time[0].start,end=time[0].end; i < length ; i++)
{
if(time[i].start<=end){
int t = time[i].end - start ;
end < time[i].end?end=time[i].end:end;
t > maxBusy?maxBusy = t : t;
}else{
int t = time[i].start - end;
end = time[i].end;
start = time[i].start;
t > maxFree?maxFree = t : t;
t = time[i].end - time[i].start ;
t > maxBusy?maxBusy = t : t;
}
}
fout<<maxBusy<<" "<<maxFree<<endl;
delete []time;
}
return 0;
}
结果:
USER: jim zhai [jszhais1] TASK: milk2 LANG: C++ Compiling... Compile: OK Executing... Test 1: TEST OK [0.000 secs, 3360 KB] Test 2: TEST OK [0.000 secs, 3360 KB] Test 3: TEST OK [0.000 secs, 3360 KB] Test 4: TEST OK [0.000 secs, 3360 KB] Test 5: TEST OK [0.000 secs, 3360 KB] Test 6: TEST OK [0.000 secs, 3360 KB] Test 7: TEST OK [0.000 secs, 3360 KB] Test 8: TEST OK [0.000 secs, 3360 KB] All tests OK.答案:
We read the list of times, sort it by start time, and then walk over the list once, merging overlapping times. Then we walk the list watching for long milking periods and long non-milking periods.
An alternate approach would be to just keep an array of size a million and mark off times. On a nice fast processor, that's probably fast enough, but our above algorithm will work even on slow processors, and it's not much harder to write.
#include <stdio.h> #include <stdlib.h> #include <string.h> #include <assert.h> #define MAXMILKING 5000 typedef struct Milking Milking; struct Milking { int begin; int end; }; Milking milking[MAXMILKING]; int nmilking; int milkcmp(const void *va, const void *vb) { Milking *a, *b; a = (Milking*)va; b = (Milking*)vb; if(a->begin > b->begin) return 1; if(a->begin < b->begin) return -1; return 0; } void main(void) { FILE *fin, *fout; int i, j, t, tmilk, tnomilk; Milking cur; fin = fopen("milk2.in", "r"); fout = fopen("milk2.out", "w"); assert(fin != NULL && fout != NULL); /* read input, sort */ fscanf(fin, "%d", &nmilking); for(i=0; i<nmilking; i++) fscanf(fin, "%d %d", &milking[i].begin, &milking[i].end); qsort(milking, nmilking, sizeof(Milking), milkcmp); /* walk over list, looking for long periods of time */ /* tmilk = longest milking time */ /* tnomilk = longest non-milking time */ /* cur = current span of milking time being considered */ tmilk = 0; tnomilk = 0; cur = milking[0]; for(i=1; i<nmilking; i++) { if(milking[i].begin > cur.end) { /* a down time */ t = milking[i].begin - cur.end; if(t > tnomilk) tnomilk = t; t = cur.end - cur.begin; if(t > tmilk) tmilk = t; cur = milking[i]; } else { if(milking[i].end > cur.end) cur.end = milking[i].end; } } /* check final milking period */ t = cur.end - cur.begin; if(t > tmilk) tmilk = t; fprintf(fout, "%d %d\n", tmilk, tnomilk); exit(0); }