Dual Palindromes

Dual Palindromes
Mario Cruz (Colombia) & Hugo Rickeboer (Argentina)

A number that reads the same from right to left as when read from left to right is called a palindrome. The number 12321 is a palindrome; the number 77778 is not. Of course, palindromes have neither leading nor trailing zeroes, so 0220 is not a palindrome.

The number 21 (base 10) is not palindrome in base 10, but the number 21 (base 10) is, in fact, a palindrome in base 2 (10101).

Write a program that reads two numbers (expressed in base 10):

  • N (1 <= N <= 15)
  • S (0 < S < 10000)
and then finds and prints (in base 10) the first N numbers strictly greater than S that are palindromic when written in two or more number bases (2 <= base <= 10).

Solutions to this problem do not require manipulating integers larger than the standard 32 bits.

PROGRAM NAME: dualpal

INPUT FORMAT

A single line with space separated integers N and S.

SAMPLE INPUT (file dualpal.in)

3 25

OUTPUT FORMAT

N lines, each with a base 10 number that is palindromic when expressed in at least two of the bases 2..10. The numbers should be listed in order from smallest to largest.

SAMPLE OUTPUT (file dualpal.out)

26
27
28
代码:
/* 
 ID: jszhais1 
 PROG: dualpal 
 LANG: C++ 
 */  

//#include "stdafx.h"
//#include <iostream>
#include <fstream> 
using namespace std;

int main()
{
	ofstream fout("dualpal.out");  
    ifstream fin("dualpal.in"); 
	int zs_hexConversion(int num , const int &hex,char* zs_Num);
	bool isPalindromes(int length,const char* zs_Num);
	char zs_Num[2048];
	int N,S,count_s=0,length;
	fin>>N>>S;
	while(count_s<N)
	{
		S++;
		int count_n=0;
		for(int hex=2;count_n<2&&hex<=10;hex++)
		{
			length = zs_hexConversion(S,hex,zs_Num);
			if(isPalindromes(length,zs_Num))
			{count_n++;}

		}
		if(count_n>=2)
		{
			count_s++;
			fout<<S<<endl;
		}
	}

	return 0;
}

int zs_hexConversion(int num , const int &hex,char* zs_Num)
{
	int i=0,tempN=0;
	for(;num!=0;i++)
	{
		tempN = num%hex;
		num = num/hex;
		zs_Num[i]='0'+tempN;
	}
	zs_Num[i]='\0';
	return i;
}

bool isPalindromes(int length,const char* zs_Num)
{
	length--;
	for(int i=0;i<length;i++,length--)
	{
		if(zs_Num[i]!=zs_Num[length])
			return false;
	}
	return true;
}
思路:
考察进制转化,数据量不大故采用暴力循环法即可。
结果:
USER: jim zhai [jszhais1]
TASK: dualpal
LANG: C++


Compiling...
Compile: OK


Executing...
   Test 1: TEST OK [0.000 secs, 3356 KB]
   Test 2: TEST OK [0.000 secs, 3356 KB]
   Test 3: TEST OK [0.000 secs, 3356 KB]
   Test 4: TEST OK [0.000 secs, 3356 KB]
   Test 5: TEST OK [0.000 secs, 3356 KB]
   Test 6: TEST OK [0.000 secs, 3356 KB]
   Test 7: TEST OK [0.000 secs, 3356 KB]


All tests OK.
Your program ('dualpal') produced all correct answers!  This is your
submission #2 for this problem.  Congratulations!


Here are the test data inputs:


------- test 1 ----
5 1
------- test 2 ----
9 10
------- test 3 ----
15 9900
------- test 4 ----
10 90
------- test 5 ----
12 125
------- test 6 ----
12 1900
------- test 7 ----
8 500
Keep up the good work!
Thanks for your submission!
答案:
Dual Palindromes
Russ Cox

Dual palindromes are actually very common, a fact we can test by writing a program such as this one.

Since they are very common, we can just use a brute force search to test all numbers bigger than s until we find enough dual palindromes.

How do we know they are common enough? Write the brute force program (which is very simple and thus not much effort) and check.

This reasoning is a little circular, but if we had been wrong and ended up needing a more clever and more efficient algorithm, we would have this brute force version to test against.

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <assert.h>

/* is string s a palindrome? */
int
ispal(char *s)
{
    char *t;

    t = s+strlen(s)-1;
    for(t=s+strlen(s)-1; s<t; s++, t--)
	if(*s != *t)
	    return 0;

    return 1;
}

/* put the base b representation of n into s: 0 is represented by "" */
char*
numbconv(char *s, int n, int b)
{
    int len;

    if(n == 0) {
	strcpy(s, "");
	return s;
    }

    /* figure out first n-1 digits */
    numbconv(s, n/b, b);

    /* add last digit */
    len = strlen(s);
    s[len] = "0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZ"[n%b];
    s[len+1] = '\0';
    return s;
}

/* is number n a dual palindrome? */
int
isdualpal(int n)
{
    int i, j, npal;
    char s[40];

    npal = 0;
    for(i=2; i<=10; i++)
	if(ispal(numbconv(s, n, i)))
	    npal++;

    return npal >= 2;
}

void
main(void)
{
    FILE *fin, *fout;
    int n, s;

    fin = fopen("dualpal.in", "r");
    fout = fopen("dualpal.out", "w");
    assert(fin != NULL && fout != NULL);

    fscanf(fin, "%d %d", &n, &s);

    for(s++; n>0; s++) {
	if(isdualpal(s)) {
	    fprintf(fout, "%d\n", s);
	    n--;
	}
    }

    exit(0);
}
USACO Gateway |  Comment or Question

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值