采用邻接矩阵表示法创建无向图G ,依次输出各顶点的度。
输入格式:
输入第一行中给出2个整数i(0<i≤10),j(j≥0),分别为图G的顶点数和边数。 输入第二行为顶点的信息,每个顶点只能用一个字符表示。 依次输入j行,每行输入一条边依附的顶点。
输出格式:
依次输出各顶点的度,行末没有最后的空格。
输入样例:
5 7
ABCDE
AB
AD
BC
BE
CD
CE
DE
结尾无空行
输出样例:
2 3 3 3 3
结尾无空行
作者
王东
单位
贵州师范学院
代码长度限制
16 KB
时间限制
400 ms
内存限制
64 MB
#include <stdio.h>
#include <string.h>
/* run this program using the console pauser or add your own getch, system("pause") or input loop */
int main(int argc, char *argv[]) {
int i,j;
scanf("%d%d",&i,&j);
getchar();
char str[11],ch0,ch1;
scanf("%s",str);
getchar();
int n = 0;
char a[11],b[11];
if(j!=0){
while(j--){
scanf("%c%c",&ch0,&ch1);
getchar();
a[n] = ch0;
b[n] = ch1;
n += 1;
}
int k,t,m;
for(k=0;k<strlen(str);k++){
t = 0;
for(m=0;m<n;m++){
if (str[k] == a[m]){
t++;
}else if(str[k] == b[m]){
t++;
}
}
printf("%d",t);
if(k!=(strlen(str)-1)){
printf(" ");
}
}
}else if(j == 0){
int k;
for(k=0;k<strlen(str);k++){
printf("0");
if(k!=(strlen(str)-1)){
printf(" ");
}
}
}
return 0;
}