A Knight's Journey(搜索题)

A Knight's Journey
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Background
The knight is getting bored of seeing the same black and white squares 
again and again

 and has decided to make a journey                                                     
around the world. Whenever a knight moves, it is two
 squares in one direction and one square perpendicular to this. 
The world of a knight is the chessboard he is living on.
 Our knight lives on a chessboard that has a smaller 

area than a regular 8 * 8 board, but it is still rectangular. 
Can you help this adventurous knight to make travel plans? 

Problem
Find a path such that the knight visits every square once. 
The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. 
Each test case consists of a single line with two positive integers p and q, 
such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 
1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:",
 where i is the number of the scenario starting at 1. 
Then print a single line containing the lexicographically first path that visits all squares of the chessboard 
with knight moves followed by an empty line. 
he path should be given on a single line by concatenating the names of the visited squares.
 Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4
 
   
题意:

按照骑士路线行走是否能将所有的点全部走完(一个小于8*8的棋盘)并按照字典序

来进行输出所走的路的坐标先输出列(A,B,C,D,E,F,G)

再输出行(1,2,3,4,5,6,7,8);

由于要求按照字典许输出路线则按照

int dx[8] = {-1, 1, -2,2, -2, 2, -1, 1};

int dy[8] = {-2, -2, -1,-1, 1, 1, 2, 2};//为了使其按照字典序排列且先输出列则

按照Y从小到大走即可。(且X也要按照从小到大)

(在Y相同的情况下按照象限第三、第二、第四、第一的顺序来进行)

代码:

#include <iostream>
#include <cstring>
#include <string>
#include <algorithm>
#include <cstdio>
using namespace std;
int map[88][88];
int vis[88][88];
int n,m;
int flag;
int dx[8] = {-1, 1, -2, 2, -2, 2, -1, 1};
int dy[8] = {-2, -2, -1, -1, 1, 1, 2, 2};//为了使其按照字典序排列且
先输出列则按照Y从小到大走即可。(且X也要按照从小到大)(在Y相同的情况下
按照象限第三、第二、第四、第一的顺序来进行)
void DFS(int x,int y,int step)
{
    map[step][0]=x;
    map[step][1]=y;
    if(step==n*m)
    {
        flag=1;
        return ;
    }
    for(int i=0; i<8; i++)
    {
        int nx=x+dx[i];
        int ny=y+dy[i];
        if(nx<1||nx>n||ny<1||ny>m||vis[nx][ny]||flag)
            continue;
        else
        {
            vis[nx][ny]=1;
            DFS(nx,ny,step+1);
            vis[nx][ny]=0;
        }
    }

}
int main()
{
    int i,j;
    int t;
    cin>>t;
    int countt=0;
    while(t--)
    {  flag=0;
      scanf("%d%d",&n,&m);
        memset(vis,0,sizeof(vis));
        vis[1][1]=1;
        DFS(1,1,1);

        cout<<"Scenario #"<<++countt<<":"<<endl;
        if(flag)
        {

            for(int i=1; i<=n*m; i++)
            {
                printf("%c%d",map[i][1]-1+'A',map[i][0]);
            }
        }
        else
           printf("impossible");
           printf("\n");

        if(t)
            printf("\n");
    }
    return 0;
}







  • 2
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值