HDOJ 1050 Moving Tables(贪心)

Moving Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 24356    Accepted Submission(s): 8064


Problem Description
The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.



The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.



For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.
 

Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.
 

Output
The output should contain the minimum time in minutes to complete the moving, one per line.
 

Sample Input
  
  
3 4 10 20 30 40 50 60 70 80 2 1 3 2 200 3 10 100 20 80 30 50
 

Sample Output
  
  
10 20 30
 

Source
 

Recommend
We have carefully selected several similar problems for you:   1052  1789  1045  1053  1800

大致翻译:
南北各200间房间,中间有一走廊。现要将若干特定房间的椅子搬到指导房间,一条走廊只能允许一把椅子过去,已知每个椅子从任意房间到任意房间的时间都是10分钟,求经过最优分配后所需的最短时间。
输入:第一行测试个数,第二行要搬几(n)把椅子,后面分别输入椅子的起始房间和终点房间号(n组每组一行)。
输出:一共所需最短时间。


这道题据说可以用贪心算法解出,但我还是用了别的方案(更easy)。原理如下:
  先创建一个函数f(),输入的是任意房间号,输出的是走廊的位置。比如1号房间和2号房间都对应位置1的走廊,3号房间和4号房间对应位置2的走廊,一共有200个这样的位置。我用a[201]定义这些位置,其中某位置的值就是经历这个位置的次数。如果从某一号房到另一号房,所经历的每个位置的次数都+1,最后再全体扫描下哪个位置经历次数最多,输出值便是这个位置的值*10。不要遗忘可能起始房间号比终止房间号大:
Ex:
1
3
10 20
30 20
100 10
*********
30


0MS   AC:
#include<stdio.h>
#include<string.h>
int f(int a){
    if(a%2==1) return (a+1)/2;
    else return a/2;
}//计算此房间对应的走廊段,一共分成200段
int main(){
    int t,n,i,j,max,a[201],star,end,temp;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        memset(a,0,sizeof(a));
        for(i=0;i<n;i++){
            scanf("%d%d",&star,&end);
            if(star>end) {
                temp=star;
                star=end;
                end=temp;
            }//特殊情况  起始房间号比终止房间号大
            for(j=f(star);j<=f(end);j++)
                a[j]++;//累加计数
        }
        max=-1;
        for(i=0;i<201;i++)
            if(max<a[i]) max=a[i];
        printf("%d\n",max*10);
    }
    return 0;
}


 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值